corsasport.co.uk
 

Corsa Sport » Message Board » Help Zone, Modification and ICE Advice » C20XE Lambda and non-lambda looms and ecu...


New Topic

New Poll
  Subscribe | Add to Favourites

You are not logged in and may not post or reply to messages. Please log in or create a new account or mail us about fixing an existing one - register@corsasport.co.uk

There are also many more features available when you are logged in such as private messages, buddy list, location services, post search and more.


Author C20XE Lambda and non-lambda looms and ecu...
dragon2309
Member

Registered: 1st Mar 09
Location: Strood, Kent
User status: Offline
23rd Jan 12 at 20:08   View User's Profile U2U Member Reply With Quote

Evening all, heres one for the c20xe pro's among us..

I have a late c20xe, the manifold it came with has a lambda hole in it, and some random 1 wire lambda sensor in it with cut-off wires. I dont have the ecu or loom that the engine was running with.

I need to buy a loom and ecu for a late dispak engine, with a lambda (i assume, as theres one in the manifold). A loom and ecu has come up for a late xe, its a PT ecu, and the loom came with that ECU when it was bought. Thing is that loom doesnt appear to ahve a lambda plug in it... So it's a pre-lambda, late xe..??

Now, does that even exist? As i would have assumed all late xe's would be running a lambda sensor? And if it does indeed exist (a PT ECU and matched loom without a lambda sensor) can i use it on my late xe engine, even though it clearly has a lambda sensor inn the ex manifold (blank it off obviously).

Would the engine run fine? Or is it somehow dependant on the lambda sensor in some other way aswell? Ideas?

Cheers, dave.
Darryl H
Organiser: South Central
Premium Member


Avatar

Registered: 19th Nov 09
Location: Camberley Drives: Porsche 944
User status: Offline
23rd Jan 12 at 23:50   View Garage View User's Profile U2U Member Reply With Quote

Mine has a non lambda loom and runs fine, If you earth pin 20 on the ECU it acts as if it didn't have a lambda and runs like a 20XE so I would assume the previous owner was running it like that?


|My Corsa|SC|My Instagram|
dragon2309
Member

Registered: 1st Mar 09
Location: Strood, Kent
User status: Offline
24th Jan 12 at 00:05   View User's Profile U2U Member Reply With Quote

Ah interesting, thanks for the info darryl.

Well, im not overly sure, the lambda in the manifold looks old, and only has 1 purple wire, and has what looks like the remains of a crimp connector on the end of it, but its only about 6" long.

Did you do the pin20 earthing thing on yours then mate? Also, is it a PT ECU your running with that?
Darryl H
Organiser: South Central
Premium Member


Avatar

Registered: 19th Nov 09
Location: Camberley Drives: Porsche 944
User status: Offline
24th Jan 12 at 00:51   View Garage View User's Profile U2U Member Reply With Quote

It's how the 20xe looms are done mate, mine runs like it and runs fine, slightly rich but apparently that's down to my AFM which needs changing. Not had any problems so far (touch wood)

I've done the pin 20 thing as I ran it without any lambda or earthing and it overfuelled like a boss Still ran OK though


|My Corsa|SC|My Instagram|
Linch
Member

Registered: 4th May 06
Location: Whickham, Tyne and Wear
User status: Offline
24th Jan 12 at 16:52   View User's Profile U2U Member Reply With Quote

If its a coil pack xe, ecu PT (Cav/Cally) or PL (Astra GSI) will be fine but I would say the loom will have lambda plug on it, up beside where the loom go's into the car.
dragon2309
Member

Registered: 1st Mar 09
Location: Strood, Kent
User status: Offline
24th Jan 12 at 20:25   View User's Profile U2U Member Reply With Quote

quote:
Originally posted by Darryl H
It's how the 20xe looms are done mate, mine runs like it and runs fine, slightly rich but apparently that's down to my AFM which needs changing. Not had any problems so far (touch wood)

I've done the pin 20 thing as I ran it without any lambda or earthing and it overfuelled like a boss Still ran OK though
Hmm, ok. Thanks for the confirmation, cheers

quote:
Originally posted by Linch
If its a coil pack xe, ecu PT (Cav/Cally) or PL (Astra GSI) will be fine but I would say the loom will have lambda plug on it, up beside where the loom go's into the car.
Hi linch, yeh its a coilpack xe. The ECU im looking at now is PT sot hats fine, i assumed all alte ones would have a lambda? Maybe the loom does have a plug for it and the guy looking just missed it? I know they are fairly close tot he ECU connector, as the plug sits up by the bulkhead on the left hand side. Usually. lol. Will get him to confirm, as there arent any other plugs on an xe loom that are 3 pins in a row... they're all 2 pin sensors or 4-pin for afm ro start/charge loom connector thingy...

Thanks for replaies, dave.

 
New Topic

New Poll

  Related Threads Author Forum Replies Views Last Post
Oxygen sensor Mistamist General Chat 10 802
15th Jul 05 at 19:04
by corb
 
c20xe ecu's corsaandy Help Zone, Modification and ICE Advice 4 426
27th Jun 05 at 10:45
by corsaandy
 
fuel replay/ wiring help Doug_SRi Help Zone, Modification and ICE Advice 9 3110
27th Oct 05 at 14:39
by Doug_SRi
 
XE Loom... and 16v Corsa Loom... and behind glove box?.. Davidkent Help Zone, Modification and ICE Advice 2 295
8th Dec 09 at 23:06
by Davidkent
 
lambda sensor question nathan87 Help Zone, Modification and ICE Advice 0 362
28th Sep 10 at 21:45
by nathan87
 

Corsa Sport » Message Board » Help Zone, Modification and ICE Advice » C20XE Lambda and non-lambda looms and ecu... 28 database queries in 0.0132802 seconds