corsasport.co.uk
 

Corsa Sport » Message Board » Help Zone, Modification and ICE Advice » Engine managment light problem


New Topic

New Poll
  Subscribe | Add to Favourites

You are not logged in and may not post or reply to messages. Please log in or create a new account or mail us about fixing an existing one - register@corsasport.co.uk

There are also many more features available when you are logged in such as private messages, buddy list, location services, post search and more.


Author Engine managment light problem
Dav
Member

Registered: 23rd Jul 02
Location: Falkirk, Scotland
User status: Offline
   11th May 03 at 21:01   View User's Profile U2U Member Reply With Quote

My engine managment light has come on and I don't know why.

When it came on I was going along the motorway accelerating just over 80mph when the car suddenly stopped pulling for a second, like I had stamped really hard on the brakes. Then it came back to life but was sort of lumpy for a while. Now the car has massive flat spots where it doesn't accelerate around 2000rpm in every gear. It also doesn't seem to accelerate has hard and almost doesn't accelerate at all over approx 70 to 80mph. And the engine is ticking more than normal.

What have I done to my car? Does anyone know what might be wrong?

I'm gonna have to take it to a garage anyway coz I don't have a clue about engines, but I thought I'd ask on here so I have a rough idea what it might be...

It's not been my lucky day
Cheers.
MillerCorsa
Member

Registered: 30th Jan 03
User status: Offline
11th May 03 at 22:40   View User's Profile U2U Member Reply With Quote

As someone will probably let us know, there is a thread regarding how to read the fault in memory, used by the EMS.

It involves inserting a wire into 2 terminals on your fusebox, which is to be honest a bit cheaper than the 50quid its going to cost for a garage to hook it up to the fault reading box!

Sounds like it could be a simple problem, such as sparks etc, check all your engine is looking ok, and everything is plugged in correctly, look out for leakages.

Miller
Sam
Moderator
Premium Member


Registered: 24th Dec 99
Location: West Midlands
User status: Offline
12th May 03 at 08:41   View User's Profile U2U Member Reply With Quote

If you want to check the diagnostic fault codes out yourself, you can just use a paperclip to short two pins on the main engine ECU diagnostic port (usually where the fusebox is), the two pins you need to short depend on the type of engine management system you have (ie. Motronic/Multec/Simtec etc.).

There is a guide on how to read fault codes on this web site:

http://www.topbuzz1.carenthusiasts.co.uk/info/fault_codes/fault_codes.htm

Another fault code list for things such as auto gearbox, 4x4, ABS, etc.:

http://www.akirwan.freeserve.co.uk/akhow2/diag_no3.rtf


[Edited on 12/05/03 by Sam]
Dav
Member

Registered: 23rd Jul 02
Location: Falkirk, Scotland
User status: Offline
12th May 03 at 08:41   View User's Profile U2U Member Reply With Quote

Thanks Miller, do you know where this thread for reading memory faults is? Got a link?

I should also say that my car is revving high/low between 500 and 1500rpm on idle, and I think maybe over fueling.

Also Rob_Scarborough sent me a U2U with a few idea's. Thanks mate.
Mr 106
Member

Registered: 1st Oct 02
User status: Offline
12th May 03 at 08:44   View User's Profile U2U Member Reply With Quote

another afm
miles
Member

Registered: 25th Mar 02
Location: plymouth Drives: Astra Sport
User status: Offline
12th May 03 at 12:46   View User's Profile U2U Member Reply With Quote

dont the 1.2 16v's use map sensors and not afm's?

Sam
Moderator
Premium Member


Registered: 24th Dec 99
Location: West Midlands
User status: Offline
12th May 03 at 13:02   View User's Profile U2U Member Reply With Quote

I'm quite sure they use MAP sensors.
blebo
Member

Registered: 18th Apr 02
User status: Offline
12th May 03 at 13:39   View User's Profile U2U Member Reply With Quote

1999 1.2 16V....this means that the paper clip trick dosent work.....or at least It didnt on my sxi
Wolf In Welsh Clothing
Member

Registered: 31st Mar 03
Location: North Wales...... Cooper S on order
User status: Offline
12th May 03 at 15:10   View User's Profile U2U Member Reply With Quote

quote:
Originally posted by blebo
1999 1.2 16V....this means that the paper clip trick dosent work.....or at least It didnt on my sxi

16 pin diagnostic reading:
connect the XX with a paper clip and turn the ignition on, dont start the engine though!

0 0
0 0
X 0
X 0
0 0
0 0
0 0
0 0

every code is 4 digits long and will flash 3 times, if the light stays off then no codes are stored. If a code begines with a 1 then it is a vauxhall specific code, all codes begining 0 can be found at On Board Diagnostics.
10,4,10,10,10,4,10,10,10,4,10,10, is code 0400 EGR valve.
Hope this helps.

10,4,10,10 would flash 10 times, pause for 1 sec, flash 4 times, pause for 1 sec, flash 10 times, pause for 1 sec, flash 10 times, pause for 2/3 secs.

[Edited on 12-05-2003 by Wolf In Welsh Clothing]
Dav
Member

Registered: 23rd Jul 02
Location: Falkirk, Scotland
User status: Offline
12th May 03 at 21:44   View User's Profile U2U Member Reply With Quote

Cheers everyone. I'll see what I can do tomorrow. Will probably take it to a few garages to see what they say coz they'll know better than me obviously.

Thanks for all the help and advice, I appreciate it
Jamog
Member

Registered: 14th Sep 02
Location: Scotland
User status: Offline
9th Nov 03 at 23:10   View User's Profile U2U Member Reply With Quote

I know this was posted along time ago but... was just wondering what was the solution to this. My car has just developed a similar fault and its pissing me off.
luca2020
Member

Registered: 26th May 02
Location: Maidstone, Kent
User status: Offline
10th Nov 03 at 01:24   View User's Profile U2U Member Reply With Quote

quote:
Originally posted by Dav
Cheers everyone. I'll see what I can do tomorrow. Will probably take it to a few garages to see what they say coz they'll know better than me obviously.

Thanks for all the help and advice, I appreciate it


ud think that wouldent u, dont bet ur money on it tho

they will use a cheeper version of the TEC1 or TEC2 diagnostic tools that vaux use and will charge u

to find out the excat same result of what a garage would tell u, do the paper clip test, it spits out the same info weather u do it or a garage does it, so save ur self money and do it ur self

 
New Topic

New Poll

  Related Threads Author Forum Replies Views Last Post
What sensor could this be?? blebo Help Zone, Modification and ICE Advice 14 1585
1st Mar 03 at 14:04
by jjcymru
 
Problems under the bonnet, pls help Rob_Scarborough Help Zone, Modification and ICE Advice 19 1492
17th Jul 04 at 22:24
by Rover Dave
 
Engine Problem Saga Part Deux Rob_Scarborough General Chat 7 1205
2nd Jun 05 at 23:21
by 306CORSA
 
EGR valve Dav Help Zone, Modification and ICE Advice 12 3024
28th Nov 03 at 13:18
by paulr202000
 
Squealing at cold start up..????? mav Help Zone, Modification and ICE Advice 14 1496
6th Dec 03 at 11:43
by vibrio
 

Corsa Sport » Message Board » Help Zone, Modification and ICE Advice » Engine managment light problem 27 database queries in 0.0161891 seconds