corsasport.co.uk
 

Corsa Sport » Message Board » Help Zone, Modification and ICE Advice » My amp wont work????


New Topic

New Poll
  Subscribe | Add to Favourites

You are not logged in and may not post or reply to messages. Please log in or create a new account or mail us about fixing an existing one - register@corsasport.co.uk

There are also many more features available when you are logged in such as private messages, buddy list, location services, post search and more.


Author My amp wont work????
crazycorza
Member

Registered: 28th Mar 02
Location: SP Styling, Preston
User status: Offline
9th Jul 03 at 21:56   View User's Profile U2U Member Reply With Quote

I'v run power lead,phonos and earth ok, but no power to the amp????
Do i need to use a lead for remote???
The headunit is a top of the range Kenwood, rrp 350 will it need remote run??

I have never had this problem before, what could be the problem, as the amp power light dont even come on??
Richie
Member

Registered: 3rd Dec 02
Location: Newport, Wales
User status: Offline
9th Jul 03 at 22:04   View User's Profile U2U Member Reply With Quote

Yes, you need to connect up the remote lead otherwise the amp wont turn on.
crazycorza
Member

Registered: 28th Mar 02
Location: SP Styling, Preston
User status: Offline
9th Jul 03 at 22:11   View User's Profile U2U Member Reply With Quote

Does it just run from the rear of the head unit to the amp??
Richie
Member

Registered: 3rd Dec 02
Location: Newport, Wales
User status: Offline
9th Jul 03 at 22:43   View User's Profile U2U Member Reply With Quote

yup.

 
New Topic

New Poll

  Related Threads Author Forum Replies Views Last Post
win 2000 Adam-D General Chat 21 799
16th Apr 03 at 20:11
by Gizmo
 
oooo errrrr not good Adam-D General Chat 13 646
14th Oct 03 at 19:28
by Adam-D
 
ALLOYS? corsa_crew North East 17 574
24th Jan 04 at 09:12
by chillout
 
What is 'Copy Image BB Code' ? dave17 General Chat 15 475
11th Feb 04 at 07:35
by the_legend_of_yrag
 
fao ice buffs aussiac Help Zone, Modification and ICE Advice 1 445
7th May 04 at 17:03
by 1800ed
 

Corsa Sport » Message Board » Help Zone, Modification and ICE Advice » My amp wont work???? 27 database queries in 0.0107582 seconds