corsasport.co.uk
 

Corsa Sport » Message Board » Help Zone, Modification and ICE Advice » Engine problems.Pls help me out people!


New Topic

New Poll
  Subscribe | Add to Favourites

You are not logged in and may not post or reply to messages. Please log in or create a new account or mail us about fixing an existing one - register@corsasport.co.uk

There are also many more features available when you are logged in such as private messages, buddy list, location services, post search and more.


Author Engine problems.Pls help me out people!
corsa c14se
Member

Registered: 17th Sep 02
Location: Athens,Greece
User status: Offline
7th Jul 03 at 07:42   View User's Profile U2U Member Reply With Quote

I've got an SRi '94.My engine sometimes revs erratically up&down without pressing the gas pedal.It can go up to 2000rpm for a few minutes and then drop down again.If I switch off the engine and switch it on the problem usually goes away.After some minutes though I get the same problems again.It does that both when the engine is cold and when its hot.The engine management light on the dash does not come on to indicate a mulfunction.Any ideas?
KittedCorsa
Member

Registered: 2nd Feb 03
Location: Corby, Northants - Drives Corsa 1.4 Sport
User status: Offline
7th Jul 03 at 09:56   View User's Profile U2U Member Reply With Quote

i am havin the same problem mate, its a pain in the ass. mine sometimes struggles 2 find idle speed when i start it as well.
only seems 2 run eractically when the egr blower is on.
n e ideas from n e one wud help.
Corsa^Dan
Member

Registered: 4th Dec 02
Location: Sleaford, Lincolnshire
User status: Offline
7th Jul 03 at 10:01   View User's Profile U2U Member Reply With Quote

idle control valve?
corsa c14se
Member

Registered: 17th Sep 02
Location: Athens,Greece
User status: Offline
7th Jul 03 at 10:02   View User's Profile U2U Member Reply With Quote

My first thought was the idle cntrol valve.I changed it with a new one but the problem persists.I checked the vacum hoses of the injection system but they too are OK.I don't have an erg on mine so it's not this that causes the problem.
I don't know if an aftermarket programmable ECU will solve the problem.Anyone?

[Edited on 07-07-2003 by corsa c14se]
Wolf In Welsh Clothing
Member

Registered: 31st Mar 03
Location: North Wales...... Cooper S on order
User status: Offline
7th Jul 03 at 12:54   View User's Profile U2U Member Reply With Quote

Easy things to try is disconnecting the electrical plugs to the egr and the secondary air injection pump.
You will get the management light come on but you'll be able to see if it runs the same with it disconnected.
Another thing to try might be disconnecting the lambda sensor.
Might be worth replacing the coolant temp sensor aswel.
CORSALUVA
Member

Registered: 6th Nov 01
Location: MANCHESTER
User status: Offline
7th Jul 03 at 13:05   View User's Profile U2U Member Reply With Quote

guys, where is the idele control valve and what doesit look like.

I am having a similar problem butim getting an enginer management code of 35 - idle air control

any one help??
CORSALUVA
Member

Registered: 6th Nov 01
Location: MANCHESTER
User status: Offline
8th Jul 03 at 09:27   View User's Profile U2U Member Reply With Quote

ttt
miles
Member

Registered: 25th Mar 02
Location: plymouth Drives: Astra Sport
User status: Offline
8th Jul 03 at 13:10   View User's Profile U2U Member Reply With Quote

depends on the engine.

Aftermarket management is a big expense for a harmless problem!

it could be an air leak.
grigglet33
Member

Registered: 23rd Mar 01
Location: East Sussex
User status: Offline
8th Jul 03 at 13:14   View User's Profile U2U Member Reply With Quote

Throttle position switch was my problem, same syptoms as you guys are having
gsi-gaz
Member

Registered: 23rd Mar 03
Location: st helens
User status: Offline
1st Aug 04 at 10:16   View User's Profile U2U Member Reply With Quote

i had the same probs on my gsi not long ago,

changed the icv and throttle position snesor and it still dint cure it!

turned out to be an air leak

 
New Topic

New Poll

  Related Threads Author Forum Replies Views Last Post
Why you don't use NOS... Craig W General Chat 31 2561
26th Feb 03 at 08:19
by vibrio
 
C14SE Engine Mods Sam Help Zone, Modification and ICE Advice 7 3310
2nd Apr 03 at 15:27
by Gambit
 
How much should I be looking at for an engine conversion?? Makarus Help Zone, Modification and ICE Advice 31 2855
19th Jun 03 at 06:08
by lee mitchell
 
MGF - Spec Savinforcorsaproject General Chat 19 1322
23rd Sep 03 at 22:52
by mistdotcom
 
Head Gaskets whitter45 Help Zone, Modification and ICE Advice 13 1123
12th Dec 03 at 22:31
by whitter45
 

Corsa Sport » Message Board » Help Zone, Modification and ICE Advice » Engine problems.Pls help me out people! 27 database queries in 0.0147021 seconds