corsasport.co.uk
 

Corsa Sport » Message Board » Help Zone, Modification and ICE Advice » 1.4 16 valve strange problem, need urgent help!


New Topic

New Poll
  Subscribe | Add to Favourites

You are not logged in and may not post or reply to messages. Please log in or create a new account or mail us about fixing an existing one - register@corsasport.co.uk

There are also many more features available when you are logged in such as private messages, buddy list, location services, post search and more.


Author 1.4 16 valve strange problem, need urgent help!
jamesw
Member

Registered: 28th Jun 02
Location: Station Town, County Durham
User status: Offline
24th Jun 03 at 14:01   View User's Profile U2U Member Reply With Quote

Hi, just replaced injector number 1 on my corsa sri, now when i start it, its runs fine for about 15 secs then starts to rev all the way up, it would rev to the limit if i let it, any advice anyone???????


Cheers,

JW
miles
Member

Registered: 25th Mar 02
Location: plymouth Drives: Astra Sport
User status: Offline
24th Jun 03 at 14:05   View User's Profile U2U Member Reply With Quote

you have an air leak.
miles
Member

Registered: 25th Mar 02
Location: plymouth Drives: Astra Sport
User status: Offline
24th Jun 03 at 14:09   View User's Profile U2U Member Reply With Quote

I'll expand.

Does it rev smoothly or is it missing?

Try resetting the ECU.

A problem that nearly caught me out is that when I removed an old injector the O ring stayed in the fuel rail, I nearly didn't notice, this cause an air leak.

With the engine running spray some carb cleaner or something around the inlet and injectors to see if the engine note changes.

I take it you have to remove the upper inlet manifold. That can be a pain to seal. Becarefull that you dont thread the manifold, its only alu and the bolts are only 6ft/lb.

Did you use a new gasket? If not I actually just used instant gasket on mine and it worked fine.
jamesw
Member

Registered: 28th Jun 02
Location: Station Town, County Durham
User status: Offline
24th Jun 03 at 14:26   View User's Profile U2U Member Reply With Quote

using the old o ring as i only replaced 1 injector, revs going straight through the roof now as soon as it starts, and throttle deffo not open =0\


JW
miles
Member

Registered: 25th Mar 02
Location: plymouth Drives: Astra Sport
User status: Offline
24th Jun 03 at 14:47   View User's Profile U2U Member Reply With Quote

my money is on an air leak.
jamesw
Member

Registered: 28th Jun 02
Location: Station Town, County Durham
User status: Offline
24th Jun 03 at 14:50   View User's Profile U2U Member Reply With Quote

ok mate gonna have to take another look =0( , it should just be a straight swap shouldnt it?

JW
miles
Member

Registered: 25th Mar 02
Location: plymouth Drives: Astra Sport
User status: Offline
24th Jun 03 at 15:06   View User's Profile U2U Member Reply With Quote

should be yes. Unless the O rings were knackered.
jamesw
Member

Registered: 28th Jun 02
Location: Station Town, County Durham
User status: Offline
24th Jun 03 at 15:26   View User's Profile U2U Member Reply With Quote

ok cheers mate u been loads of help =0)


JW
miles
Member

Registered: 25th Mar 02
Location: plymouth Drives: Astra Sport
User status: Offline
24th Jun 03 at 21:45   View User's Profile U2U Member Reply With Quote

No problem.

 
New Topic

New Poll

  Related Threads Author Forum Replies Views Last Post
Engine problems.Pls help me out people! corsa c14se Help Zone, Modification and ICE Advice 9 1660
1st Aug 04 at 10:16
by gsi-gaz
 
EGR valve Dav Help Zone, Modification and ICE Advice 12 3126
28th Nov 03 at 13:18
by paulr202000
 
Squealing at cold start up..????? mav Help Zone, Modification and ICE Advice 14 1710
6th Dec 03 at 11:43
by vibrio
 
The 'ECOTEC' martin@BBG Help Zone, Modification and ICE Advice 33 3276
4th Mar 04 at 11:56
by Mossy01772
 
Whooping Cough Red_SXi General Chat 16 1130
6th Mar 04 at 18:42
by Paul_J
 

Corsa Sport » Message Board » Help Zone, Modification and ICE Advice » 1.4 16 valve strange problem, need urgent help! 27 database queries in 0.0135860 seconds