corsasport.co.uk
 

Corsa Sport » Message Board » Help Zone, Modification and ICE Advice » Problem with a X16XEL engine - idling problem


New Topic

New Poll
  Subscribe | Add to Favourites

You are not logged in and may not post or reply to messages. Please log in or create a new account or mail us about fixing an existing one - register@corsasport.co.uk

There are also many more features available when you are logged in such as private messages, buddy list, location services, post search and more.


Author Problem with a X16XEL engine - idling problem
Red_SXi
Member

Registered: 23rd Sep 02
Location: Dunstable Drives: 52 Plate BMW 3 M Sport Coupe
User status: Offline
8th Mar 05 at 11:11   View User's Profile U2U Member Reply With Quote

When we first got the car the Engine management light was on, and it would cut out as you dropped the clutch down at junctions etc, its still cutting out but the engine management light isn't on any more.

Any idea's what it could be ? I was think ICV but you lot know more than me
Red_SXi
Member

Registered: 23rd Sep 02
Location: Dunstable Drives: 52 Plate BMW 3 M Sport Coupe
User status: Offline
8th Mar 05 at 11:12   View User's Profile U2U Member Reply With Quote

Ps. I might of got the engine code wrong
Rileysport
Member

Registered: 18th Jun 04
Location: West Yorkshire
User status: Offline
8th Mar 05 at 11:31   View User's Profile U2U Member Reply With Quote

Vehicle speed sensor, mine did it
PaulW
Member

Registered: 26th Jan 03
Location: Atherton, Greater Manchester
User status: Offline
8th Mar 05 at 11:39   View User's Profile U2U Member Reply With Quote

yup VSS did it to mine too... once!

Was told I needed to get some new dials as mine were cable driven, but didn't need to as its all ok now...

except the speedo needle waves about 30mph
Red_SXi
Member

Registered: 23rd Sep 02
Location: Dunstable Drives: 52 Plate BMW 3 M Sport Coupe
User status: Offline
8th Mar 05 at 12:27   View User's Profile U2U Member Reply With Quote

That explains alot, as the speedo isn't working. ABS light is on too tho :s
Rileysport
Member

Registered: 18th Jun 04
Location: West Yorkshire
User status: Offline
8th Mar 05 at 12:28   View User's Profile U2U Member Reply With Quote

check the fuses dude... bet you theres one gone, speedo may read off the abs sensors so start with fuses/relays for abs first
Red_SXi
Member

Registered: 23rd Sep 02
Location: Dunstable Drives: 52 Plate BMW 3 M Sport Coupe
User status: Offline
8th Mar 05 at 12:29   View User's Profile U2U Member Reply With Quote

Although i have heard the Speedo works from the ABS system, so i presumed it was that
Red_SXi
Member

Registered: 23rd Sep 02
Location: Dunstable Drives: 52 Plate BMW 3 M Sport Coupe
User status: Offline
8th Mar 05 at 12:29   View User's Profile U2U Member Reply With Quote

Fuses have been checked and they're all fine. What and where is the VSS ?
Rileysport
Member

Registered: 18th Jun 04
Location: West Yorkshire
User status: Offline
8th Mar 05 at 12:35   View User's Profile U2U Member Reply With Quote

its integral with the clocks, but if you've got an abs warning thats where the problem will be for definate
Red_SXi
Member

Registered: 23rd Sep 02
Location: Dunstable Drives: 52 Plate BMW 3 M Sport Coupe
User status: Offline
8th Mar 05 at 12:36   View User's Profile U2U Member Reply With Quote

Could that problem be to do with it cutting out too do you reckon?
Rileysport
Member

Registered: 18th Jun 04
Location: West Yorkshire
User status: Offline
8th Mar 05 at 12:57   View User's Profile U2U Member Reply With Quote

Yeah if your speedo pick up is off the abs system and this has gone tits up then theres no signal to the vss, this would cause the car to display a vss fault code and cut out under the cicumstances you are describing
Red_SXi
Member

Registered: 23rd Sep 02
Location: Dunstable Drives: 52 Plate BMW 3 M Sport Coupe
User status: Offline
8th Mar 05 at 12:58   View User's Profile U2U Member Reply With Quote

Cheers mate, you're a great help Car should hopefully be for sale this week
Rileysport
Member

Registered: 18th Jun 04
Location: West Yorkshire
User status: Offline
8th Mar 05 at 13:05   View User's Profile U2U Member Reply With Quote

No worries dude
Siberia
Member

Registered: 9th Oct 03
Location: Leprechaun Land Drives : Zafira GSI
User status: Offline
8th Mar 05 at 13:23   View User's Profile U2U Member Reply With Quote

different car.... different engine.... but when my speedo cable was snaped on my corsa it would cut out when you pressed in the clutch at junctions etc...
Rileysport
Member

Registered: 18th Jun 04
Location: West Yorkshire
User status: Offline
8th Mar 05 at 13:27   View User's Profile U2U Member Reply With Quote

for the same reason

 
New Topic

New Poll

  Related Threads Author Forum Replies Views Last Post
1.2 running terrible JOHN M Help Zone, Modification and ICE Advice 13 2152
28th Aug 06 at 14:19
by KIFF
 
FAO, Engine wizards... TOMAS Help Zone, Modification and ICE Advice 15 1469
18th Oct 03 at 18:43
by TOMAS
 
c20xe Corsa b idling problems finch1 Help Zone, Modification and ICE Advice 6 1071
15th Oct 04 at 17:59
by finch1
 
ok so any clue at all? sassyminx Help Zone, Modification and ICE Advice 18 709
5th Nov 04 at 09:49
by sassyminx
 
revs dropping quite low Jake Help Zone, Modification and ICE Advice 21 838
26th Feb 05 at 11:19
by corsaSXI.com
 

Corsa Sport » Message Board » Help Zone, Modification and ICE Advice » Problem with a X16XEL engine - idling problem 27 database queries in 0.0130439 seconds