corsasport.co.uk
 

Corsa Sport » Message Board » Help Zone, Modification and ICE Advice » Juddering when cold but fine when warm?! NEED HELP!


New Topic

New Poll
  Subscribe | Add to Favourites

You are not logged in and may not post or reply to messages. Please log in or create a new account or mail us about fixing an existing one - register@corsasport.co.uk

There are also many more features available when you are logged in such as private messages, buddy list, location services, post search and more.


Author Juddering when cold but fine when warm?! NEED HELP!
nibnob21
Premium Member

Avatar

Registered: 16th May 10
Location: South Derbyshire
User status: Offline
29th Sep 10 at 21:04   View Garage View User's Profile U2U Member Reply With Quote

Hey guys,

I have a small persistent problem with the car.

When the weather's cold the car doesn't start very well. It will judder and splutter, but give it 10 minutes when the car is warmed up and it drives fine again

It did it a bit in the spring when I first got the car so I serviced it including a spark plug change. The only things I didn't change were the HT leads.

I also put some STP injector and carb fuel treatment through the system and with the service as well, it seemed to improve...but the weather was getting better then too so it could have just been that?!

Obviously over the summer the car's been absolutely fine as the weather has been warmer but it's cold and wet this morning and so the car was all crappy until it got warmed up.

So for the first 10 mins or so every time I would pull out of a junction or try to accelerate the car would judder and splutter kind of like it was trying to stall.

And the engine management light isn't coming on so I'm hoping it isn't a huge problem?!

Oh and it did it before I drilled and derestricted my airbox so I don't think it's anything to do with that as my car doesn't have a MAF sensor.

It's a X14SZ engine by the way.

Someone help me pleeeeaaaaaaase!


MX5 Project Thread
Jake
Member

Registered: 24th Jan 05
User status: Offline
29th Sep 10 at 21:07   View User's Profile U2U Member Reply With Quote

i have a similar problem with my car and its the distributer playing up

[Edited on 29-09-2010 by jake]
nibnob21
Premium Member

Avatar

Registered: 16th May 10
Location: South Derbyshire
User status: Offline
29th Sep 10 at 21:11   View Garage View User's Profile U2U Member Reply With Quote

Is that an easy or cheap fix?


MX5 Project Thread
nibnob21
Premium Member

Avatar

Registered: 16th May 10
Location: South Derbyshire
User status: Offline
29th Sep 10 at 21:14   View Garage View User's Profile U2U Member Reply With Quote

And is there anything else it might be?


MX5 Project Thread

 
New Topic

New Poll

  Related Threads Author Forum Replies Views Last Post
a strange one....automatic choke or ICV maybe? russb Help Zone, Modification and ICE Advice 7 1961
10th Mar 05 at 23:36
by russb
 
c20xe problem Wayne Help Zone, Modification and ICE Advice 9 767
4th Aug 05 at 02:19
by muppetsport
 
starting from cold (essay warning) eazy187 Help Zone, Modification and ICE Advice 21 441
1st Jun 07 at 12:15
by dan_c4rsa
 
free(ish) power from your x14xe / x16xe as long as you have a spare 50mm sock filter Dave A General Chat 272 10149
19th Sep 07 at 16:48
by Dave A
 
juddering eug Help Zone, Modification and ICE Advice 2 282
3rd May 08 at 10:20
by eug
 

Corsa Sport » Message Board » Help Zone, Modification and ICE Advice » Juddering when cold but fine when warm?! NEED HELP! 28 database queries in 0.0096102 seconds