corsasport.co.uk
 

Corsa Sport » Message Board » Help Zone, Modification and ICE Advice » Indicators arent working on 1 side


New Topic

New Poll
  Subscribe | Add to Favourites

You are not logged in and may not post or reply to messages. Please log in or create a new account or mail us about fixing an existing one - register@corsasport.co.uk

There are also many more features available when you are logged in such as private messages, buddy list, location services, post search and more.


Author Indicators arent working on 1 side
Ian_83
Member

Registered: 27th Dec 09
User status: Offline
27th Dec 09 at 18:22   View User's Profile U2U Member Reply With Quote

Hello, I don't own a corsa myself, I use owners forums for my car a lot for my car. I thought i'd ask the experts for some advice for a friend.

She has a 55 plate corsa C and has lost indicators down 1 side of her car. So she can signal left (i think) but can't signal right. WHen she puts hazard lights on, its the same deal. They are blinking twice as fast as they should with the lack of resistance (i think!). I thought it might have been the stalk, until she said about the hazards being the same. I'm thinking maybe a lose wire somewhere?

Cheers!

Ian
am4nf
Member

Registered: 27th Jul 08
Location: South Ayrshire Drives: Corsa Sport
User status: Offline
27th Dec 09 at 18:25   View User's Profile U2U Member Reply With Quote

They flash if a bulb is out, find what bulb is out and change it

(all other working bulbs will still work)

[Edited on 27-12-2009 by am4nf]
Ian_83
Member

Registered: 27th Dec 09
User status: Offline
27th Dec 09 at 18:57   View User's Profile U2U Member Reply With Quote

its all 3 indicators down 1 side of the car so i figured it wasnt a bulb?
am4nf
Member

Registered: 27th Jul 08
Location: South Ayrshire Drives: Corsa Sport
User status: Offline
27th Dec 09 at 20:53   View User's Profile U2U Member Reply With Quote

fuse
djgritt
Premium Member

Avatar

Registered: 1st Nov 07
Location: North Dorset Drives: Monaro SC / Abarth595
User status: Offline
27th Dec 09 at 22:21   View Garage View User's Profile U2U Member Reply With Quote

I had similar on my B, Fuse was the cause
Ste M
Member

Registered: 28th Oct 09
Location: Blackpool
User status: Offline
27th Dec 09 at 22:41   View User's Profile U2U Member Reply With Quote

Isn't when an indicator lights flashes faster than normal it's down to a fuse?
am4nf
Member

Registered: 27th Jul 08
Location: South Ayrshire Drives: Corsa Sport
User status: Offline
28th Dec 09 at 01:45   View User's Profile U2U Member Reply With Quote

nope can be either
Ian
Site Administrator

Avatar

Registered: 28th Aug 99
Location: Liverpool
User status: Offline
28th Dec 09 at 01:57   View Garage View User's Profile U2U Member Reply With Quote

If it flashes faster, its because the relay isn't seeing as much load, which is consistent with what you're seeing.

Check the fuse.


Corsa B lap belts required
Ant
Member

Registered: 12th May 02
Location: Hereford and Worcester
User status: Offline
29th Dec 09 at 03:08   View User's Profile U2U Member Reply With Quote

flasher unit or relay is common fault also on c's one unit works both sides but they are still known to fail only across one side, fuse is easier to check first though
Ian_83
Member

Registered: 27th Dec 09
User status: Offline
29th Dec 09 at 11:33   View User's Profile U2U Member Reply With Quote

She's tried the fuse, and it was fine. She said the fuse was for all the indicators, not just 1 side. Where's the relay on the corsa? I'm used to jap cars so i wouldn't know where to start.
shauny bizzle
Member

Registered: 2nd Aug 06
Location: Sheppey, Kent Drives: Vectra GSI V6
User status: Offline
30th Dec 09 at 12:46   View User's Profile U2U Member Reply With Quote

the relay is in the bcm, its the small black cover near the battery it has about 4 torx screws in it and its the big yellow relay, my c did it, i have one somewhere mate
Ian_83
Member

Registered: 27th Dec 09
User status: Offline
31st Dec 09 at 00:38   View User's Profile U2U Member Reply With Quote

ok cheers. Your C did the same thing?
Ian_83
Member

Registered: 27th Dec 09
User status: Offline
31st Dec 09 at 00:55   View User's Profile U2U Member Reply With Quote

If its not the relay, where is the flasher unit? Is there a way to test it?
Adam-D
Member

Registered: 11th May 02
Location: Cheshire
User status: Offline
31st Dec 09 at 08:34   View User's Profile U2U Member Reply With Quote

its normally the yellow relay. put you hazzards on, see if funky stuff happens, one side may work other may work intermittantly or not at all

vaux carry the relay in stock, ive changed a few now, getting more common as they get older
Ian_83
Member

Registered: 27th Dec 09
User status: Offline
31st Dec 09 at 12:20   View User's Profile U2U Member Reply With Quote

Fair do's cheers lads. I'll get the information to her. She did mention the other night it was working intermittantly for a bit. Got a part number for the Vaux dealers? Or is it something i can go into a scrappy and whip out of a corsa B?

 
New Topic

New Poll

  Related Threads Author Forum Replies Views Last Post
Sparking Help will h Help Zone, Modification and ICE Advice 13 294
17th Sep 05 at 13:48
by will h
 
Dodgy Indicators CorsaKen1 Help Zone, Modification and ICE Advice 12 737
11th May 07 at 12:42
by Chris_Sport
 
HELP! Brake lights and indicators are f***ed! TimHarrison Help Zone, Modification and ICE Advice 3 609
21st May 07 at 20:21
by dan_c4rsa
 
Indicators not working / What fuse to check??? Tarrantino Help Zone, Modification and ICE Advice 10 14918
30th Jul 08 at 09:39
by Tarrantino
 
1993 Corsa GSi c16xe N/A mar_cus Projects and Builds 26 1194
27th May 09 at 18:52
by mar_cus
 

Corsa Sport » Message Board » Help Zone, Modification and ICE Advice » Indicators arent working on 1 side 28 database queries in 0.0192070 seconds