corsasport.co.uk
 

Corsa Sport » Message Board » Off Day » Geek Day » Sky and routing mail through smtp servers


New Topic

New Poll
  Subscribe | Add to Favourites

You are not logged in and may not post or reply to messages. Please log in or create a new account or mail us about fixing an existing one - register@corsasport.co.uk

There are also many more features available when you are logged in such as private messages, buddy list, location services, post search and more.


Author Sky and routing mail through smtp servers
Andrew
Member

Registered: 5th May 04
Location: Skoda Octavia Estate, Ford Puma
User status: Offline
11th Nov 09 at 16:30   View User's Profile U2U Member Reply With Quote

I'm having an issue routing mail through Sky smtp servers using exchange 2007. Any geeks done this before?

Using port 465, smtp server of smtp.tools.sky.com and authenticated credientials.

Opened the port on the sky router but cannot see this being an issues as outgoing traffic should not be blocked.
willay
Moderator
Organiser: South East, National Events
Premium Member


Avatar

Registered: 10th Nov 02
Location: Roydon, Essex
User status: Offline
11th Nov 09 at 16:52   View Garage View User's Profile U2U Member Reply With Quote

465/tcp = SMTP over SSL/TLS, have you configured the SSL/TLS part?
Andrew
Member

Registered: 5th May 04
Location: Skoda Octavia Estate, Ford Puma
User status: Offline
11th Nov 09 at 17:05   View User's Profile U2U Member Reply With Quote

Nothing to allow SSL/TLS on the router.
Andrew
Member

Registered: 5th May 04
Location: Skoda Octavia Estate, Ford Puma
User status: Offline
11th Nov 09 at 17:06   View User's Profile U2U Member Reply With Quote

Also done an nslookup and tried routing through IP for the smtp sever. It's being a right cunt
Andrew
Member

Registered: 5th May 04
Location: Skoda Octavia Estate, Ford Puma
User status: Offline
11th Nov 09 at 17:17   View User's Profile U2U Member Reply With Quote

Option for TLC in Exchange, tried this and does not work.

Any Exchange 2007 geeks on here that want to dial in and have a look what i've missed?
willay
Moderator
Organiser: South East, National Events
Premium Member


Avatar

Registered: 10th Nov 02
Location: Roydon, Essex
User status: Offline
11th Nov 09 at 17:28   View Garage View User's Profile U2U Member Reply With Quote

If the router has NAT enabled and you dont have a outgoing access-list you wont need to enable the port out of the router.

What you need to find out is if Exchange 2007 can forward mail via a SMTP server with SSL/TLS encryption/authetnication enabled
willay
Moderator
Organiser: South East, National Events
Premium Member


Avatar

Registered: 10th Nov 02
Location: Roydon, Essex
User status: Offline
11th Nov 09 at 17:28   View Garage View User's Profile U2U Member Reply With Quote

quote:
Originally posted by Andrew
Also done an nslookup and tried routing through IP for the smtp sever. It's being a right cunt


what are you barking on about?
willay
Moderator
Organiser: South East, National Events
Premium Member


Avatar

Registered: 10th Nov 02
Location: Roydon, Essex
User status: Offline
11th Nov 09 at 17:29   View Garage View User's Profile U2U Member Reply With Quote

PS - why dont you just forward via normal SMTP on port 25 on that host? See below.

[willay@myhost~]$ telnet smtp.tools.sky.com 25
Trying 74.125.79.208...
Connected to bskyb-smtp.l.google.com.
Escape character is '^]'.
220 mx.google.com ESMTP 7sm831524eyg.41
HELO
250 mx.google.com at your service
Andrew
Member

Registered: 5th May 04
Location: Skoda Octavia Estate, Ford Puma
User status: Offline
11th Nov 09 at 19:29   View User's Profile U2U Member Reply With Quote

I had the same issue on the standard port 25.

I've either fucked something up or sky are being cunts and lot letting me pipe the mail down their server.

Checked with another SBS2008 set up and done exacally the same. Going to try and pipe through googlemail direct and then get a contractor to have a look next time he is in.
willay
Moderator
Organiser: South East, National Events
Premium Member


Avatar

Registered: 10th Nov 02
Location: Roydon, Essex
User status: Offline
11th Nov 09 at 19:48   View Garage View User's Profile U2U Member Reply With Quote

just try doing it on the server itsself, for example open up cmd and type 'telnet smtp.tools.sky.com 25' if the screen goes blank with a flashing cursor that means you've made a successful connection, if it just says trying or something along them lines its getting through.

Also try it on another PC on the same network to see if the problem is isolated to the server or not.

If you find that your PC can do it fine, then look at any firewall software you have on the server or AV program that could be blocking it (ive come across AV doing it before).

If your PC cant do it , then go over your settings on your router and make sure its not blocked, if you are 100% sure it isnt blocked on your local router then the likelyhood is Sky has blocked it.

Lots of broadband isps these days are blocking out going ports such as TCP 25, and TCP 445 because tcp/25 is to do with spam control and port 445 is a typical port that windows worm/viruses attack other windows boxes on.

Hope this helps, report back your findings.
Andrew
Member

Registered: 5th May 04
Location: Skoda Octavia Estate, Ford Puma
User status: Offline
11th Nov 09 at 20:34   View User's Profile U2U Member Reply With Quote

yeah, flashing curser using port 465. Some random text when telneting to port 25 regarding mx records for google.

I'm now begining to think this is set up correctly and working fine but i've fucked something else up
willay
Moderator
Organiser: South East, National Events
Premium Member


Avatar

Registered: 10th Nov 02
Location: Roydon, Essex
User status: Offline
11th Nov 09 at 22:25   View Garage View User's Profile U2U Member Reply With Quote

Sky might have google to host their smtp, i think i read that somewhere ages ago.

Just do it without the TLS shit and it should be fine, I'll speak to my exchange guy tomorrow or if you can give me access to it I'll have a poke around

 
New Topic

New Poll

  Related Threads Author Forum Replies Views Last Post
SMTP outgoing mail Drew General Chat 17 587
11th Apr 04 at 12:03
by Nismo
 
Just Received this email from pipex sukhwant Geek Day 4 345
30th Sep 05 at 17:03
by Ian
 
Corsasport E-Mail Dean_W Geek Day 10 396
26th Mar 06 at 13:16
by Dean_W
 
SMTP settings... Robin Geek Day 2 322
13th Jan 08 at 13:48
by Robin
 

Corsa Sport » Message Board » Off Day » Geek Day » Sky and routing mail through smtp servers 28 database queries in 0.0182760 seconds