corsasport.co.uk
 

Corsa Sport » Message Board » Help Zone, Modification and ICE Advice » anyone had a PAS pump go on there corsa?


New Topic

New Poll
  Subscribe | Add to Favourites

You are not logged in and may not post or reply to messages. Please log in or create a new account or mail us about fixing an existing one - register@corsasport.co.uk

There are also many more features available when you are logged in such as private messages, buddy list, location services, post search and more.


Author anyone had a PAS pump go on there corsa?
truman69
Member

Registered: 12th Jan 06
Location: mansfield, notts
User status: Offline
31st Mar 06 at 16:03   View User's Profile U2U Member Reply With Quote

well my car as only done 28k but got a funny noise thats comes and goes and been told it may be my PAS pump also been told they cost a lot 2
if anyone as had this happen b4 can you tell how much it cost and if it made funny nosies
Corsa E-Tec
Member

Registered: 4th Feb 04
Location: Stevenage Drives: Leon Cupra
User status: Offline
31st Mar 06 at 16:05   View User's Profile U2U Member Reply With Quote

makes sure you have enough power steering fluid in the bottle.
Robin
Premium Member

Avatar

Registered: 7th Jan 04
Location: Northants Drives: Clio 182 Cup
User status: Offline
31st Mar 06 at 16:07   View Garage View User's Profile U2U Member Reply With Quote

mine used to make funny noises, then the engine died

(the 2 incidents are not related)
X 60RSA
Member

Registered: 20th Aug 01
Location: Lincoln
User status: Offline
31st Mar 06 at 16:08   View User's Profile U2U Member Reply With Quote

28k?

That the pump or the car........aren't most new ish corsa's on EPS now.....
Robin
Premium Member

Avatar

Registered: 7th Jan 04
Location: Northants Drives: Clio 182 Cup
User status: Offline
31st Mar 06 at 16:10   View Garage View User's Profile U2U Member Reply With Quote

Dave, my T-reg corsa has only done about 24k, so i recon its pump not EPS
truman69
Member

Registered: 12th Jan 06
Location: mansfield, notts
User status: Offline
31st Mar 06 at 16:14   View User's Profile U2U Member Reply With Quote

car done 28k on a t reg. power steering fluid is fine. hope it dont die on me
aovertonwba
Member

Registered: 31st Oct 05
Location: Mere Green, West Midlands
User status: Offline
31st Mar 06 at 16:44   View User's Profile U2U Member Reply With Quote

on my 99 sxi i have eps, dont think it needs fluid
bubble
Member

Registered: 24th Jan 04
Location: Darwin, NT Australia.
User status: Offline
31st Mar 06 at 17:28   View User's Profile U2U Member Reply With Quote

quote:
Originally posted by truman69
car done 28k on a t reg. power steering fluid is fine. hope it dont die on me


that should be an electric motor then, not fluid
Robin
Premium Member

Avatar

Registered: 7th Jan 04
Location: Northants Drives: Clio 182 Cup
User status: Offline
31st Mar 06 at 17:34   View Garage View User's Profile U2U Member Reply With Quote

like i said, mines a T and has fluid PAS
bubble
Member

Registered: 24th Jan 04
Location: Darwin, NT Australia.
User status: Offline
31st Mar 06 at 17:43   View User's Profile U2U Member Reply With Quote

quote:
Originally posted by robmarriott
like i said, mines a T and has fluid PAS


urs a x14xe, or x16xe? im sure the x12xe variants had EPS due to not having a pulley for power steering.
Robin
Premium Member

Avatar

Registered: 7th Jan 04
Location: Northants Drives: Clio 182 Cup
User status: Offline
31st Mar 06 at 17:49   View Garage View User's Profile U2U Member Reply With Quote

it WAS an X14XE

i know all the X10XE's had EPS, but i thought the X12XE was normal PAS
Wrighty
Member

Registered: 28th Feb 04
Location: Howden
User status: Offline
31st Mar 06 at 17:53   View User's Profile U2U Member Reply With Quote

u can hear a noise when i turn my steering wheel,thought nothing of it though...
Robin
Premium Member

Avatar

Registered: 7th Jan 04
Location: Northants Drives: Clio 182 Cup
User status: Offline
31st Mar 06 at 17:56   View Garage View User's Profile U2U Member Reply With Quote

a slight hissing noise?

its normal
Wrighty
Member

Registered: 28th Feb 04
Location: Howden
User status: Offline
31st Mar 06 at 19:19   View User's Profile U2U Member Reply With Quote

quote:
Originally posted by robmarriott
a slight hissing noise?

its normal


yes

and i thought so
Sam
Moderator
Premium Member


Registered: 24th Dec 99
Location: West Midlands
User status: Offline
31st Mar 06 at 23:18   View User's Profile U2U Member Reply With Quote

X12XE has EPS.

 
New Topic

New Poll

  Related Threads Author Forum Replies Views Last Post
Bit of a clearout jjcymru Parts Offered 4 754
7th Mar 04 at 03:19
by jjcymru
 
i dont understand why....(c20xe) bubble Help Zone, Modification and ICE Advice 24 978
26th Jun 05 at 17:03
by jamesw
 
quick help...xe and pas mossy General Chat 5 456
23rd Oct 05 at 18:35
by timrud_
 
Power Steering Conversion ed Help Zone, Modification and ICE Advice 5 343
20th Feb 06 at 18:49
by ed
 

Corsa Sport » Message Board » Help Zone, Modification and ICE Advice » anyone had a PAS pump go on there corsa? 27 database queries in 0.0142341 seconds