corsasport.co.uk
 

Corsa Sport » Message Board » Help Zone, Modification and ICE Advice » stalls when engine is cold?

Combe Tickets


New Topic

New Poll
  Subscribe | Add to Favourites

You are not logged in and may not post or reply to messages. Please log in or create a new account or mail us about fixing an existing one - register@corsasport.co.uk

There are also many more features available when you are logged in such as private messages, buddy list, location services, post search and more.


Author stalls when engine is cold?
Foz
Member

Registered: 8th May 02
Location: Bristol
User status: Offline
15th Feb 04 at 23:07   View User's Profile U2U Member Reply With Quote

what does this mean? engine cuts out if u dont giv it some revs. but fine once you get going.
MikeH
Member

Registered: 3rd Apr 03
User status: Offline
15th Feb 04 at 23:23   View User's Profile U2U Member Reply With Quote

Mine does the same.

My theory (and it might be wrong) is that the air mass flowmeter could be dirty. The ecu will be reading the amount of air wrong and this effect will be magnified when the engine is cold and the auto choke is on.

I'm planning to try and clean my air mass flowmeter and my idle control valve if i figure how to get them off.
Kym
Member

Registered: 27th Jun 03
Location: Fife
User status: Offline
16th Feb 04 at 00:07   View User's Profile U2U Member Reply With Quote

I had a similar prob with mine, engine cut out, then left for bout 5 mins, started again and was fine.
was told it was the mass air flow meter and that i needed a new 1 (which wasnt cheap!), only to discover it wasnt that at all.

turned out to b the crankshaft sensor and has been fine ever since.

might b the air flow meter though, hav a tendancy to fu@k up in vauxhalls!

hope this may help u!
Foz
Member

Registered: 8th May 02
Location: Bristol
User status: Offline
17th Feb 04 at 09:14   View User's Profile U2U Member Reply With Quote

i had the Idle control valve done cost me 150 and then this happens, i reckon its sumut 2 do with the BFO filter, all i get is flat spots and problems.
DJGoMatt
Member

Registered: 5th Nov 02
Location: Leeds
User status: Offline
17th Feb 04 at 12:25   View User's Profile U2U Member Reply With Quote

i've had this problem for months now, got the ecu checked - and cleared all the faults...still happening but no faults. i've changed the ICV, its still happening, changed the coolant controll sensor, still happening, cleaned injectors, throttle.
body etc with carb cleaner........ still
happening!
Might try the crankshaft sensor now.
vibrio
Banned

Registered: 28th Feb 01
Location: POAH
User status: Offline
17th Feb 04 at 13:27   View User's Profile U2U Member Reply With Quote

if it;s only when cold it suggests that the car is not getting enough petrol
Foz
Member

Registered: 8th May 02
Location: Bristol
User status: Offline
17th Feb 04 at 13:31   View User's Profile U2U Member Reply With Quote

What to do then?
DJGoMatt
Member

Registered: 5th Nov 02
Location: Leeds
User status: Offline
17th Feb 04 at 14:00   View User's Profile U2U Member Reply With Quote

thats what you'd expect, so i went for the things that controll temp and fuel. hoping that a sensor was getting the wrong temp. but no luck.
think im gonna go for the crankshaft sensor next.

not a big problem for me now, cos ive sold it to a mate. he knows about the problem but thinks he can fix it.

you tried cleaning out your throttle body and air filter foz?
Foz
Member

Registered: 8th May 02
Location: Bristol
User status: Offline
17th Feb 04 at 15:45   View User's Profile U2U Member Reply With Quote

ill have a pipe at it on the weekend and get back.
TOMAS
Member

Registered: 7th Aug 02
Location: Nottinghamshire
User status: Offline
17th Feb 04 at 16:39   View User's Profile U2U Member Reply With Quote

How do you clean the air mass meter? My revs have been dropping when i come off the gas, sometimes even stalls and it does it a lot during the first 3mins of driving (cold)! I only want a quick fix to get me by the next month until the valver goes in, its just getting quite bad and really annoying now. I used to have a PiperX filter but ditched it as it did me no favours
TOMAS
Member

Registered: 7th Aug 02
Location: Nottinghamshire
User status: Offline
18th Feb 04 at 13:38   View User's Profile U2U Member Reply With Quote

Bump
Foz
Member

Registered: 8th May 02
Location: Bristol
User status: Offline
20th Feb 04 at 15:55   View User's Profile U2U Member Reply With Quote

I noticed on lunch my BFO filter was abit loose and the pipe which goes to it looked mashed. gona sort it 2moz and just hope thats all wats wrong.

 
New Topic

New Poll

  Related Threads Author Forum Replies Views Last Post
running in blackula Help Zone, Modification and ICE Advice 10 799
2nd May 03 at 11:41
by paul_spurrell
 
Idea to remove flatspots MikeH Help Zone, Modification and ICE Advice 25 1616
29th Sep 08 at 19:58
by rybo8655
 
Engine Cutting out corsa 1.2 8v corsaboynick Help Zone, Modification and ICE Advice 14 706
18th Dec 03 at 18:17
by dysonm
 
Car still stalling! please help. DJGoMatt Help Zone, Modification and ICE Advice 14 740
1st Feb 04 at 15:33
by fax2004
 
Engine managment light and stalling mattjdarkstar Help Zone, Modification and ICE Advice 16 1679
20th Feb 04 at 11:37
by Mossy01772
 

Corsa Sport » Message Board » Help Zone, Modification and ICE Advice » stalls when engine is cold? 27 database queries in 0.1788230 seconds