corsasport.co.uk
 

Corsa Sport » Message Board » General Chat » FAO: Vibs (Or anyone else who knows about turbos)........................


New Topic

New Poll
  Subscribe | Add to Favourites

You are not logged in and may not post or reply to messages. Please log in or create a new account or mail us about fixing an existing one - register@corsasport.co.uk

There are also many more features available when you are logged in such as private messages, buddy list, location services, post search and more.


Author FAO: Vibs (Or anyone else who knows about turbos)........................
Stu
Member

Registered: 3rd May 00
Location: Madchester UK Drives: 2014 BMW M135i
User status: Offline
28th Sep 03 at 15:12   View User's Profile U2U Member Reply With Quote

Fitted the FMIC last weekend, took it for a run and the boost seemed to be the same as it was before I fitted it (about 12psi) no change at all really.

Took the car out for a spin today though and it is only making between 5 and 9 psi now? So I checked all the IC pipes, all seem fine and the ones I was unsure about I double jubilee clipped, just to be safe. Took it for another run..............still the same between 5 and 9 psi. I then wound the boost controller up to 15psi, the car then made 15 psi dead on, I though I had sussed it. I came round the next bend put my foot down and again 7psi??? Bizarre?

What does this sound like? I was thinking the actuator may be knackered? Anyone else got any ideas?

When I peaked at the 15psi I got a bit of wheelspin in 3rd in the dry! I have got two boost gauges, 1 Auto meter and one on the Blitz controller. Both of them were giving the same readings.

Im pretty sure its the actuator, but I was just hoping someone could confirm this. The cars booked in at RC on Friday anyway to sort the fuelling and turn the boost up to 18psi, I had a word with them and they said they will be able to diagnose and fix it anyway!

Cheers all
vibrio
Banned

Registered: 28th Feb 01
Location: POAH
User status: Offline
28th Sep 03 at 15:16   View User's Profile U2U Member Reply With Quote

sounds like a leak from somewhere.
m4tt_c
Member

Registered: 24th Mar 02
Location: essex
User status: Offline
28th Sep 03 at 15:18   View User's Profile U2U Member Reply With Quote

sorry dont know the answer. but out of interest which 200 sx you got?

i got myself a s14a now, is pretty much standard at the moment, except for an exhuast from turbo back and k&n. mine makes about 11 psi when on boost.

what mods you got on yours? how does it compare to your old corsa?

are you checking the boost pressure in the same gear all the time, as i think it changes depending what gear your in
vibrio
Banned

Registered: 28th Feb 01
Location: POAH
User status: Offline
28th Sep 03 at 15:20   View User's Profile U2U Member Reply With Quote

underload you'll produce more psi. say 15 in 3rd you'll get 16 peak in 5th
Stu
Member

Registered: 3rd May 00
Location: Madchester UK Drives: 2014 BMW M135i
User status: Offline
28th Sep 03 at 15:34   View User's Profile U2U Member Reply With Quote

Yeah, I thought it might have been a leak but Ive checked everywhere, and like I say, Ive double jubilee clipped most of the pipes on the new front mount intercooler? Ive also had a listen out or leaks and cant hear any at all? I just had a vibe that it might be actuator that is sticking open sometimes (as it doesnt happen all the time), what do you reckon?

My Nissan is a 99 S14a, have a look at...............
http://uk.photos.yahoo.com/evo_m3_321

Got a few bits on it now:
Apex FMIC
Walbro fuel pump
Blitz induction kit in stainless air box
Blitz NUR spec R
3.25" Decat
3.25" Downpipe
Turbo elbow
Cusco catch tank
Blitz SDi boost controller
Denso IK24 plugs
Modified breather system
Injectors
Apexi SAF-C
KYB's and Eibachs
Apexi Strut braces
AP clutch
Probably a few bits Ive forgotten

Compared to the corsa, hmmmmm. Standard it wasnt as quick, but now I think it is a lot faster. Top end and accelleration. It handles miles better too.

Cheers all!
Stu
Member

Registered: 3rd May 00
Location: Madchester UK Drives: 2014 BMW M135i
User status: Offline
28th Sep 03 at 15:36   View User's Profile U2U Member Reply With Quote

You get lower boost in the first 2 gears Matt cos of the boost solenoid on your car. It has boost cut in the first 2 gears (about 7psi compared to the normal 10psi)

Id get rid of it if I were you!
Kris TD
Member

Registered: 25th Mar 02
Location: Ware, Hertfordshire
User status: Offline
28th Sep 03 at 15:36   View User's Profile U2U Member Reply With Quote

could be a fuelling problem maybe.
Stu
Member

Registered: 3rd May 00
Location: Madchester UK Drives: 2014 BMW M135i
User status: Offline
28th Sep 03 at 15:37   View User's Profile U2U Member Reply With Quote

Yeah, I was thinking it might be the AFM possibly too?
m4tt_c
Member

Registered: 24th Mar 02
Location: essex
User status: Offline
28th Sep 03 at 15:37   View User's Profile U2U Member Reply With Quote

have you posted on www.sxoc.co.uk ??

they are pretty helpfull on there
vibrio
Banned

Registered: 28th Feb 01
Location: POAH
User status: Offline
28th Sep 03 at 15:40   View User's Profile U2U Member Reply With Quote

yes I was going to suggest that but I felt it was too obvious
Stu
Member

Registered: 3rd May 00
Location: Madchester UK Drives: 2014 BMW M135i
User status: Offline
28th Sep 03 at 16:34   View User's Profile U2U Member Reply With Quote

Yeah, I have but Ive only had one response, that wasnt too good. They are usually pretty good though!? Ive got my fingers crossed that its just a weak actuator, Ill get it sorted Friday whatever happens!

Posted a couple of new pics since I cleaned the engine today!
http://uk.photos.yahoo.com/evo_m3_321

 
New Topic

New Poll

Corsa Sport » Message Board » General Chat » FAO: Vibs (Or anyone else who knows about turbos)........................ 22 database queries in 0.0121610 seconds