corsasport.co.uk
 

Corsa Sport » Message Board » Help Zone, Modification and ICE Advice » Front wipers not working!


New Topic

New Poll
  Subscribe | Add to Favourites

You are not logged in and may not post or reply to messages. Please log in or create a new account or mail us about fixing an existing one - register@corsasport.co.uk

There are also many more features available when you are logged in such as private messages, buddy list, location services, post search and more.


Author Front wipers not working!
jmuckley
Member

Registered: 20th Dec 13
User status: Offline
   20th Dec 13 at 10:22   View User's Profile U2U Member Reply With Quote

Hi all, first time poster and clueless about cars so bare with me!

I have an 08 Corsa D, bought used in September. On my way home the other evening, in the rain, my front wipers decided to stop working without prior warning. They immediately stopped 'mid wipe' (sorry for crude description, only way I can describe it!), and wouldn't budge. I turned them off on the right arm (stick) and heard a click. Got myself home luckily and restarted my car thinking they'd budge, they worked for about 4/5 minutes then cut out again. The washers are spraying fluid just fine.

I waited until the following day on my lunchtime where they began to work once more. The rear wiper is working fine without any issue. The front wipers began to work again until late evening when they cut out once more. I have had someone check the fuses and the relays and everything seems fine, as I said the front washers are working without any fault. The guy who checked out my car said the fuses hadn't burnt out, as the front wipers and washers are connected to the same one (?).

This would lead me to believe that it's going to cost a hell of a lot :/

Any ideas/suggestions of similar problems? What to do?
tom130691
Premium Member

Avatar

Registered: 13th Sep 08
Location: Daventry
User status: Offline
20th Dec 13 at 11:01   View Garage View User's Profile U2U Member Reply With Quote

Does it have auto wipers ?

hopefully its just a dodgey relay or something
jmuckley
Member

Registered: 20th Dec 13
User status: Offline
20th Dec 13 at 11:13   View User's Profile U2U Member Reply With Quote

Hi Tom,

No the wipers aren't automatic. I've had the relays checked and they appear to be fine...
Root
Member

Registered: 28th Dec 08
User status: Offline
20th Dec 13 at 11:37   View User's Profile U2U Member Reply With Quote

my mates corsa D wiper motor went, it may be the motor, apparently it's somewhat common.

Because the problem is intermittent, that would suggest the fuse isn't damaged, but the relay could be.

So first, I'd replace the relay because it's cheaper, then if that doesn't work, replace the wiper motor. I'd say it's probably the motor though.
jmuckley
Member

Registered: 20th Dec 13
User status: Offline
20th Dec 13 at 12:16   View User's Profile U2U Member Reply With Quote

I'm going to get a relative who's a mechanic to give it a try then Root.

To actually describe them is quite difficult. They have cut out twice and remain u/s. Would that class is intermittent or just useless?!
Root
Member

Registered: 28th Dec 08
User status: Offline
20th Dec 13 at 12:32   View User's Profile U2U Member Reply With Quote

well basically, you've said they sometimes work and sometimes don't, that would mean the fuse is ok because they either work or are blown.

So that narrows it down to relay, wiring or motor. You've tried a relay, the wiring can't be that bad on a 5 year old car and it's unlikely so it leaves the motor.

I'd say the motors useless, it's going to cut out when you need it and that could be dangerous, that or it'll hardly work at all.

When motors go, sometimes they don't work at all and sometimes they hardly work but sometimes do because it's a failing part that's trying to work. It really does look like a motor, maybe wait for one or two more opinions but that's my guess. They're about 20 on ebay anyway
Mike
Organiser: North West and North Wales
Premium Member


Avatar

Registered: 20th May 06
Location: nr. Skipton, North Yorkshire
User status: Offline
20th Dec 13 at 12:34   View Garage View User's Profile U2U Member Reply With Quote

When they stop working can you hear the motor at all? My Combo van suddenly did this one day and it was just the nut on the motor had come loose so the motor was turning but couldn't grip the linkage to move the wipers.
jmuckley
Member

Registered: 20th Dec 13
User status: Offline
21st Dec 13 at 15:25   View User's Profile U2U Member Reply With Quote

I hear a little 'whir' just before I start the car..

How much are we potentially look at for a repair here?

 
New Topic

New Poll

  Related Threads Author Forum Replies Views Last Post
wipers dirtydan Help Zone, Modification and ICE Advice 3 398
11th Apr 05 at 14:39
by K2 HOY
 
wipers IvIarkgraham General Chat 7 584
9th Jan 06 at 19:19
by IvIarkgraham
 
what size wiper blades mrmattholmes Help Zone, Modification and ICE Advice 7 1412
1st Nov 06 at 15:34
by P1CK4D
 
Possible stupid question about sunstrips Skylined General Chat 10 493
7th Mar 07 at 22:04
by TomSBD
 
5 door front wipers replacement FAZ Help Zone, Modification and ICE Advice 8 421
29th Jul 08 at 16:06
by thrill1258
 

Corsa Sport » Message Board » Help Zone, Modification and ICE Advice » Front wipers not working! 27 database queries in 0.0090261 seconds