corsasport.co.uk
 

Corsa Sport » Message Board » General Chat » speedo help


New Topic

New Poll
  Subscribe | Add to Favourites

You are not logged in and may not post or reply to messages. Please log in or create a new account or mail us about fixing an existing one - register@corsasport.co.uk

There are also many more features available when you are logged in such as private messages, buddy list, location services, post search and more.


Author speedo help
Ben
Banned

Registered: 12th Jan 03
Location: West Yorkshire
User status: Offline
12th Apr 05 at 22:27   View User's Profile U2U Member Reply With Quote

my clocks dont work , rev counter , petrol ect works but not the speedo, any ideas?

its cable driven too .

ps how do you push the clocks back onto the cable without taking of the dome bit? in the end i just took it off
Adam-D
Member

Registered: 11th May 02
Location: Cheshire
User status: Offline
12th Apr 05 at 22:35   View User's Profile U2U Member Reply With Quote

the cable should click into place

if not check the other end is attached
they can break in the centre
Ben
Banned

Registered: 12th Jan 03
Location: West Yorkshire
User status: Offline
12th Apr 05 at 22:36   View User's Profile U2U Member Reply With Quote

it dont have a clip on the cable mate , its just the rod , noting attached to it , i am sure my old one had a clip on it
ed
Member

Registered: 10th Sep 03
Location: Northampton Drives: Fiat 500/Porsche Boxster
User status: Offline
12th Apr 05 at 22:43   View User's Profile U2U Member Reply With Quote

Cable doesn't have a clip... The dash does... Take the clocks off and see if the cable rotates while the car moves, if it doesn't the the cable is broke. Get an electric screwdriver and jam an allen key bit into the cable hole and stick the electric screwdriver so it spins anti clockwise, if the speedo moves then the speedo works ok...

 
New Topic

New Poll

Corsa Sport » Message Board » General Chat » speedo help 22 database queries in 0.0063682 seconds