corsasport.co.uk
 

Corsa Sport » Message Board » Help Zone, Modification and ICE Advice » Indicator Problem.............


New Topic

New Poll
  Subscribe | Add to Favourites

You are not logged in and may not post or reply to messages. Please log in or create a new account or mail us about fixing an existing one - register@corsasport.co.uk

There are also many more features available when you are logged in such as private messages, buddy list, location services, post search and more.


Author Indicator Problem.............
Desmond
Member

Registered: 7th Jun 00
Location: Rossington, South Yorkshire
User status: Offline
   19th Nov 04 at 13:38   View User's Profile U2U Member Reply With Quote

My indicator light (On the dash) stays permanantly on when indicator stick is either up or down, Non of the lights come on at all, and I can here a ticking noise from like behind the spedo but its not like the ticking you here when your indicators are flashing because its random, some times really fast other time doesnt do it for a bit then does tick.

Ive checked all the fuses and its not a bulb because my hazards are still working and all the lights flash normal.

Any ideas what the problem is?
Desmond
Member

Registered: 7th Jun 00
Location: Rossington, South Yorkshire
User status: Offline
19th Nov 04 at 13:41   View User's Profile U2U Member Reply With Quote

Just found this post. http://www.corsasport.co.uk/board/viewthread.php?tid=106891 I aint got a haynes manual do you know what relay it is? Where it is located? part no etc? Cheers
PaulW
Member

Registered: 26th Jan 03
Location: Greater Manchester
User status: Offline
19th Nov 04 at 14:02   View User's Profile U2U Member Reply With Quote

speak to Adam-D - he has a few indicator relays going for 6 each as vaux charge 12 for a new one...

he might know where they are too
3CorsaMeal
Member

Registered: 11th Apr 02
User status: Offline
19th Nov 04 at 14:28   View User's Profile U2U Member Reply With Quote

is either dodgy earth or a relay
PaulW
Member

Registered: 26th Jan 03
Location: Greater Manchester
User status: Offline
19th Nov 04 at 14:31   View User's Profile U2U Member Reply With Quote

if it was a dodgy earth, the indicator lights would dim & not be bright
3CorsaMeal
Member

Registered: 11th Apr 02
User status: Offline
19th Nov 04 at 15:08   View User's Profile U2U Member Reply With Quote

i've had some strange things happen cos of earth
Black Corsa SRi
Member

Registered: 25th May 02
Location: ---Stockport---- Drives: Pug 206 Roland Garros
User status: Offline
19th Nov 04 at 15:50   View User's Profile U2U Member Reply With Quote

quote:
Originally posted by PaulW
if it was a dodgy earth, the indicator lights would dim & not be bright


not neccessarily more likely to not work at all really it def worth checking the earth but sounds more likely a relay prob but hard to tell without being in the car yourself! LOL
J100RSA
Member

Registered: 4th Mar 01
Location: Thornhill, West Yorkshire
User status: Offline
19th Nov 04 at 23:23   View User's Profile U2U Member Reply With Quote

FAULTY HAZARD SWITCH
mjw_2k2
Member

Registered: 18th Sep 03
Location: Anglesey, North Wales
User status: Offline
19th Nov 04 at 23:28   View User's Profile U2U Member Reply With Quote

^ i agree, replace this!!! i got one spare u2u me
bradfincham
Member

Registered: 20th Sep 02
Location: East Of England Drives: Clio 172
User status: Offline
20th Nov 04 at 12:09   View User's Profile U2U Member Reply With Quote

its the switch mate,
id get a new one, where u click it on and off
Red_SXi
Member

Registered: 23rd Sep 02
Location: Dunstable Drives: 52 Plate BMW 3 M Sport Coupe
User status: Offline
20th Nov 04 at 13:28   View User's Profile U2U Member Reply With Quote

quote:
Originally posted by J100RSA
FAULTY HAZARD SWITCH


Yep
Desmond
Member

Registered: 7th Jun 00
Location: Rossington, South Yorkshire
User status: Offline
22nd Nov 04 at 16:37   View User's Profile U2U Member Reply With Quote

quote:
Originally posted by Red_SXi
quote:
Originally posted by J100RSA
FAULTY HAZARD SWITCH


Yep


I went to se Steve Smith who still works at vauxhall (Perrys Doncaster) He gave me the part numbers for the relay and I got one from a scrappers for 2 it sorted the problem but it keeps doing it every now and then, when it does it if I turn the hazard switch on and then of (Say with the indicator to turn left) when I turn the hazard switch off the indicators work
It may well be the hazard switch?
Richie
Member

Registered: 3rd Dec 02
Location: Newport, Wales
User status: Offline
22nd Nov 04 at 16:38   View User's Profile U2U Member Reply With Quote

Aye it is the hazard switch. On a normal working corsa, if you unplug the hazard switch, they will get the identical fault to what you are having.
BigSte
Member

Registered: 27th Aug 02
Location: Sheffield
User status: Offline
22nd Nov 04 at 16:52   View User's Profile U2U Member Reply With Quote

I can confirm the above........this happened to me when i removed the hazard switch to change my centre console
boyracer2002
Member

Registered: 10th Aug 02
Location: West Yorkshire
User status: Offline
22nd Nov 04 at 17:10   View User's Profile U2U Member Reply With Quote

that gsi did that when i bought it and all were working, works ok tho now :S
Richie
Member

Registered: 3rd Dec 02
Location: Newport, Wales
User status: Offline
23rd Nov 04 at 13:18   View User's Profile U2U Member Reply With Quote

quote:
Originally posted by BigSte
I can confirm the above........this happened to me when i removed the hazard switch to change my centre console


Try taking out ur centre console, then having to pop out really quick not having time to put it back together, then realising you have no indicators
Matt H
Member

Registered: 11th Sep 01
Location: South Yorkshire
User status: Offline
23rd Nov 04 at 21:25   View User's Profile U2U Member Reply With Quote

it works fine. your just trippin

 
New Topic

New Poll

  Related Threads Author Forum Replies Views Last Post
Drews Corsa (1 pic) Scott General Chat 62 2287
16th Nov 04 at 18:50
by Corsa_Carl
 
Indicater light flashers abnormally fast when indicating?? joeytrib8888 Help Zone, Modification and ICE Advice 13 894
18th Mar 03 at 10:46
by r.a.hadfield
 
indicators stoped working?!? brummiesxi Help Zone, Modification and ICE Advice 4 369
9th Dec 03 at 18:27
by brummiesxi
 
lexus ligts people? tiptoptim Help Zone, Modification and ICE Advice 15 839
4th Jul 04 at 15:39
by tiptoptim
 
DTM mirrors with LEDs ... question Shieldsy Help Zone, Modification and ICE Advice 4 534
10th Sep 04 at 07:00
by 5doormodder
 

Corsa Sport » Message Board » Help Zone, Modification and ICE Advice » Indicator Problem............. 27 database queries in 0.1729980 seconds