Corsa Sport » Message Board » Help Zone, Modification and ICE Advice » Corsa C intermittent cutting out » Post Reply

Combe Tickets

Post Reply
Who Can Post? All users can post new topics and all users can reply.
Formatting Mode:

Insert Bold text Insert Italicized text Insert Underlined text Insert Centered text Insert a Hyperlink Insert Email Hyperlink Insert an Image Insert Code Formatted text Insert Quoted text
HTML is Off
Smilies are On
BB Code is On
[img] Code is On
Post Options: Disable smileys?
Turn BBCode off?
Receive email notification of new replies?


posted on 9th Dec 17 at 01:52

Not much to go on as that's a fairly vague problem but my thoughts -

Crank sensor - yes perhaps and this is intermittent but normally doesn't clear straight away. So if you can restart straight after I would not suspect this so strongly. Failure mode for a dicky crank sensor is typically it'll fail, car will cut out and will either crank and not fire or not crank at all depending whether the ECU wants the signal to run the starter. Then after some delay it'll appear all as normal again and fire as normal. Or that'll be complete death of the sensor. Either way it doesn't usually fix itself right away to enable a restart.

And yes, it'll normally store a code.

Next thing in that circumstance for me is fuel trim. ie. the air/fuel mixture is being metered incorrectly and the ECU erroneously thinks it has a rich condition, it adjusts the amount of fuel downwards to try and compensate right down to the point at which there is not enough fuel to maintain idle.

Causes for this primarily twofold -

Air metering, if it thinks it has too much or the air is too dense it will up the injector pulse to compensate which in turn causes a rich burn which the lambda will detect and report. Although this is reported by the lambda sensor this condition is an issue with the incoming air. In this case the lambda is operating correctly as the air side is what has caused the problem and the lambda is merely reporting it.

Mixture metering, if the lambda sees a rich condition erroneously because the lambda itself has failed. Same outcome as above, injector pulse width will again be shortened to try and compensate the apparent excess of fuel but as the burn may have been OK the reduction will cause the failure to maintain idle.

You will probably find that disconnecting the lambda will cure it but I would strongly advise against this as a solution - all you are doing is removing the ability of the ECU to detect a problem and it will default to a safe map which gives roughly the right mixtures for the various throttle positions and load conditions, will probably run OK without the stalling but it'll almost certainly be worse on fuel and long term non-optimal mixtures are not good for plugs, bore linings and the cat.

Flickering - who knows - earth problem which is also giving you sensor problems - check all the flexible ones are in good order.

The absence of codes is also a clue - its something the ECU is not metering. Earth problem would fall in to that category as would stuff like air leaks on the intake downstream of the air flow sensor. You need to go old school if you suspect that type of thing, aerosol can of brake cleaner sprayed adjacent to the intake pipes will draw in the spray and cause the engine to rev up because its flammable.

Also get a proper code read - pedal test is not the best news. Even if you managed to get a code you've no idea whether its recent or years old. Ideally you need to clear the codes before the drive and before the subsequent reads after you've done enough mileage to store something.

Few things to try anyway :cool:


posted on 6th Dec 17 at 14:39

I've had a 2004 Corsa C SXI for a few months now and on 3 occasions the car has cut out on me. Each time it has been weeks apart. There are no warning lights on the dash and I've done the pedal test with no fault codes coming back. The battery is healthy (about 12.5 volts not running and 14 volts running).

On two of these occasions I have been approaching a turn, pressed the clutch in to drop from 3rd to 2nd, and the engine has cut out while rolling and with the clutch still pressed.

On one occasion I started the car, it idled at around 800-900 revs like normal, then the revs dropped to 0 and the engine cut out. This happened with each start until I eventually said f*** it and started driving to keep the revs up. Hasn't happened since.

I'm aware that these could all be signs of the common crankshaft sensor problem, but as I said there are no fault codes and from what I've read everyone with a failing crankshaft sensor has gotten a code?

Thanks in advance

Edit: Might also be worth saying that with the lights on, the dashboard will sometimes slightly flicker when the car is slowing down in 1st or 2nd. Could it be related?

[Edited on 06-12-2017 by VoicelessGrapefruit]