corsasport.co.uk
 

Corsa Sport » Message Board » General Chat » Heater not getting hot quick :(


New Topic

New Poll
  <<  1    2  >> Subscribe | Add to Favourites

You are not logged in and may not post or reply to messages. Please log in or create a new account or mail us about fixing an existing one - register@corsasport.co.uk

There are also many more features available when you are logged in such as private messages, buddy list, location services, post search and more.


Author Heater not getting hot quick :(
mattk
Member

Registered: 27th Feb 06
Location: St. Helens
User status: Offline
20th Dec 10 at 11:37   View User's Profile U2U Member Reply With Quote

deffo
Laney
Member

Registered: 6th May 03
Location: Leeds
User status: Offline
20th Dec 10 at 11:40   View User's Profile U2U Member Reply With Quote

As in a "this shit needs fixing asap" issue or "it'll be fine once its defrosted itself" issue?

Heater eventually ran warm and it stopped overheating when I'd pulled over...
mattk
Member

Registered: 27th Feb 06
Location: St. Helens
User status: Offline
20th Dec 10 at 11:42   View User's Profile U2U Member Reply With Quote

should be ok when its defrosted, probably wasnt the pump that was froze, it wouldnt have started if that was the case.

just whack some antifreeze in there asap
Laney
Member

Registered: 6th May 03
Location: Leeds
User status: Offline
20th Dec 10 at 11:54   View User's Profile U2U Member Reply With Quote

I topped it up when I pulled over, might've been it.

Cheers
Daveskater
Premium Member

Avatar

Registered: 29th Apr 08
Location: Oxford, UK Drives: Jap wagon
User status: Offline
20th Dec 10 at 11:55   View Garage View User's Profile U2U Member Reply With Quote

quote:
Originally posted by Sam
I had this problem in my Mondeo, it was down to a knackered thermostat (always stayed in the 'cold' area on the gauge) and the heater control cable was broken.

Garage changed the thermostat, I changed the heater cable, now my car is roasty toasty again.
Interesting.

Mine gets hot eventually, but it takes ages for any heat to register on the gauge. Started it up this morning as it hadn't been run since Friday and left it there for a while and it only just hit the 80C mark. Not sure how long it took though.

My dad's Mondeo is weird though, the temp gets to the middle really quick then stays there Almost doesn't seem right tbh.


Numberwang!

Originally posted by AlunJ
I like you Dave, you are a man of men

Originally Whatapp'd by Neo
Dave's maybe capable of a drive-by cuddle

Look at my pictures
Root
Member

Registered: 28th Dec 08
User status: Offline
20th Dec 10 at 12:34   View User's Profile U2U Member Reply With Quote

diesels are shit for heaters warming up quickly they take ages, luckily I dont have a diesel.

Mine takes a few minutes, did not know that the lower fan setting = more warmth though, usually blast mine out on 4.

  <<  1    2  >>
New Topic

New Poll

Corsa Sport » Message Board » General Chat » Heater not getting hot quick :( 23 database queries in 0.0111449 seconds