corsasport.co.uk
 

Corsa Sport » Message Board » General Chat » losing power help!!


New Topic

New Poll
  Subscribe | Add to Favourites

You are not logged in and may not post or reply to messages. Please log in or create a new account or mail us about fixing an existing one - register@corsasport.co.uk

There are also many more features available when you are logged in such as private messages, buddy list, location services, post search and more.


Author losing power help!!
louis
Member

Registered: 19th Feb 08
Location: hastings east sussex
User status: Offline
24th Mar 10 at 20:40   View User's Profile U2U Member Reply With Quote

right iv just a 1996 astra hacthback 1.4 8v of my gf's dad as my car was written of in the week!!! anyway whenever i go to accelerate or im climbing a steep hill the revs drop out of the sky and the power dissapears??? its just had a new rad and pipes put in but carnt see no obvious faults? theres also a real noisey tappin ,iv checked the oil water plugs and sparks but no obv faults???? cheers
Anty
Premium Member

Avatar

Registered: 19th Mar 08
Location: droitwich
User status: Offline
24th Mar 10 at 20:42   View Garage View User's Profile U2U Member Reply With Quote

ive got that with mine, but used wd 40, stp fuel injector, might be a bent valve ?
AK
Member

Registered: 5th Jul 00
Location: Aberdeen City
User status: Offline
24th Mar 10 at 20:48   View User's Profile U2U Member Reply With Quote

a bent valve? thats a bit random

When was it last serviced?
louis
Member

Registered: 19th Feb 08
Location: hastings east sussex
User status: Offline
24th Mar 10 at 20:48   View User's Profile U2U Member Reply With Quote

yeah i have fought that about the valve , what about the tappets could it be associated with them? the power is shockingly bad lol
louis
Member

Registered: 19th Feb 08
Location: hastings east sussex
User status: Offline
24th Mar 10 at 20:53   View User's Profile U2U Member Reply With Quote

im not sure but its due one though , i dunno wether that would be enough to remedy the problem?
AK
Member

Registered: 5th Jul 00
Location: Aberdeen City
User status: Offline
24th Mar 10 at 20:56   View User's Profile U2U Member Reply With Quote

take it to a garage - all you are going to get online is possibilities.
louis
Member

Registered: 19th Feb 08
Location: hastings east sussex
User status: Offline
24th Mar 10 at 20:57   View User's Profile U2U Member Reply With Quote

well was worth just asking eh it is a forum atfer all?
Nic Barnes
Member

Registered: 5th Apr 04
Location: nowhere near ginger people
User status: Offline
24th Mar 10 at 20:59   View User's Profile U2U Member Reply With Quote

blocked cat, ecu fault, coil problem, egr problem, afm problem, injector problem, worn rings, snapped camshaft, snapped crankshaft, ran out of fuel
louis
Member

Registered: 19th Feb 08
Location: hastings east sussex
User status: Offline
24th Mar 10 at 21:03   View User's Profile U2U Member Reply With Quote

cheers mate , certaintly aint the last problem lol
SR91
Member

Registered: 21st Jun 08
Location: Lancashire.
User status: Offline
24th Mar 10 at 21:30   View User's Profile U2U Member Reply With Quote

I reckon its something to do with the fact the cars underpowered. Should of put an xe in it with speedlines
Anty
Premium Member

Avatar

Registered: 19th Mar 08
Location: droitwich
User status: Offline
24th Mar 10 at 22:50   View Garage View User's Profile U2U Member Reply With Quote

mines hyundai.. same problerm, spoke to someone said either bent valve or cat !!

[Edited on 24-03-2010 by Anty]

 
New Topic

New Poll

Corsa Sport » Message Board » General Chat » losing power help!! 23 database queries in 0.0118690 seconds