corsasport.co.uk
 

Corsa Sport » Message Board » Help Zone, Modification and ICE Advice » anybody fitted an uprated fuel pump to corsa c20let?


New Topic

New Poll
  Subscribe | Add to Favourites

You are not logged in and may not post or reply to messages. Please log in or create a new account or mail us about fixing an existing one - register@corsasport.co.uk

There are also many more features available when you are logged in such as private messages, buddy list, location services, post search and more.


Author anybody fitted an uprated fuel pump to corsa c20let?
jamie m
Member

Registered: 3rd Oct 06
Location: Ashbourne, Derbyshire
User status: Offline
26th Mar 08 at 17:43   View User's Profile U2U Member Reply With Quote

--------------------------------------------------------------------------------

hi, i have bought a walbro 255lph in tank fuel pump for my corsa c20let, same pump as i once fitted to my nova c20let but im really struggling to get this one to fit, its very similar to the one thats in the tank already but the filter sits on the end funny and its shorter that the original pump causing it to be abit loose in the plastic casing it sits in,

any gen on what you others have done and what pumps you have bought?
phil_sutton
Member

Registered: 8th Sep 07
Location: Nottingham
User status: Offline
26th Mar 08 at 18:10   View User's Profile U2U Member Reply With Quote

That'll be the same as what ive got in mine. Mine didnt fit exactly an I needed to do some work to get it in, however it was that long ago now I have no idea what i did.
jamie m
Member

Registered: 3rd Oct 06
Location: Ashbourne, Derbyshire
User status: Offline
26th Mar 08 at 18:37   View User's Profile U2U Member Reply With Quote

good you are lol, im ment to be coming down you place saturday to use the rolling road to set my fueling and boost! but want to get this pump on before hand!
luke85
Member

Registered: 26th Nov 07
Location: Chesterfield
User status: Offline
26th Mar 08 at 19:31   View User's Profile U2U Member Reply With Quote

Ive just fitted the walbro pump in mine this afternoon, It helps if you leave the black rubber part on around the bottom of the pump when you fit it. Theres still a little movement in it now but Im sure it will be fine. Hardest part was pressing the filter onto the bottom of the pump

[Edited on 26-03-2008 by luke85]
jamie m
Member

Registered: 3rd Oct 06
Location: Ashbourne, Derbyshire
User status: Offline
26th Mar 08 at 20:38   View User's Profile U2U Member Reply With Quote

sounds like we must have differant pumps mate, the filter on mine sticks out too far and cannot slide it back down into its housing, and as for the black rubber part unsure what bit that is mate? what tank/model car was yours before mate?
luke85
Member

Registered: 26th Nov 07
Location: Chesterfield
User status: Offline
26th Mar 08 at 22:56   View User's Profile U2U Member Reply With Quote

I got the sytec one from Chris Astley, its a walbro one in a sytec box. Was it a multi point pump to start with? The pump wont slide into the housing with the filter on the bottom, I put the pump in the housing then pressed the filter on the bottom of the pump sticking out, If you get what I mean. Are you the guty from mig whos gonna borrow my wideband by the way? lol
jamie m
Member

Registered: 3rd Oct 06
Location: Ashbourne, Derbyshire
User status: Offline
27th Mar 08 at 19:05   View User's Profile U2U Member Reply With Quote

yeh mate i am if thats still ok, i no what you mean by pump in first then filter on but the filter sticks out too far once its on and cannot slide the pump housing back in the bracket, also the new pumps about 10mm shorter than the other one and rattles about inside the housing once fitted?
luke85
Member

Registered: 26th Nov 07
Location: Chesterfield
User status: Offline
27th Mar 08 at 23:00   View User's Profile U2U Member Reply With Quote

Yeah the pump being a bit shorter makes it a bit loose but I cant see that being a problem, it cant really go anywhere. Was the car multi point injection before you fitted this pump? still fine with me if you want to borrow the wideband

[Edited on 27-03-2008 by luke85]
jamie m
Member

Registered: 3rd Oct 06
Location: Ashbourne, Derbyshire
User status: Offline
28th Mar 08 at 20:35   View User's Profile U2U Member Reply With Quote

yeh was a 1400 16v mate many moons ago, il stick it in again tomoz then, uno your filter on the end did it sleeve onto the pump and have a little locating stud to get the filter in the correct place what did you do with that because it locates the filter so it sticks out the side of the pump housing and it then wont go back in its cradel

 
New Topic

New Poll

  Related Threads Author Forum Replies Views Last Post
uprated fuel pump corsa_sri04 Help Zone, Modification and ICE Advice 0 279
26th Feb 05 at 15:08
by corsa_sri04
 
Just fitted... broster General Chat 26 1293
24th Mar 05 at 17:08
by Ojc
 
Which fuel pump? C4RL0 Help Zone, Modification and ICE Advice 1 346
14th Mar 07 at 22:59
by Ben ev
 
Pacet fan or other slim fan (sport air con) & uprated fuel pump DAZ1985 Wanted 9 525
17th May 07 at 08:16
by DAZ1985
 
Nova, Corsa B & C, uprated fuel pumps, XE LET rallyman Parts Offered 1 437
10th Oct 07 at 18:02
by rallyman
 

Corsa Sport » Message Board » Help Zone, Modification and ICE Advice » anybody fitted an uprated fuel pump to corsa c20let? 28 database queries in 0.0286448 seconds