corsasport.co.uk
 

Corsa Sport » Message Board » Help Zone, Modification and ICE Advice » x16xe problems


New Topic

New Poll
  Subscribe | Add to Favourites

You are not logged in and may not post or reply to messages. Please log in or create a new account or mail us about fixing an existing one - register@corsasport.co.uk

There are also many more features available when you are logged in such as private messages, buddy list, location services, post search and more.


Author x16xe problems
corsacoley
Member

Registered: 13th Sep 07
Location: durham
User status: Offline
14th Sep 07 at 16:09   View User's Profile U2U Member Reply With Quote

right, ive got a '97 corsa sport which used to be a x14xe until the timing belt snapped, so some clown dumped a 1.6 16v lump in, which i think is the X16XE. It was running on 3 cylinders with the eml on, so i had a new wiring loom put on cuz the wiring was shat, then went from there. I replaced the ecu, which was from the 1.4, to another 1.4 ecu. It ran on all four but only revs up to 5k and the eml is still on. then i took it out the other day and after an hour or two it started idling really lumpy, then cut out. Its been doin this ever since. Do i need a 1.6 ecu? or could the faults still be stored on the ecu and just need clearing? ive tried disconnecting the battery. I'm a bit stuck, any help would be appreciated
gsirick
Member

Registered: 18th Feb 07
Location: mid-wales
User status: Offline
14th Sep 07 at 16:24   View User's Profile U2U Member Reply With Quote

try doin the paperclip test and see what fault codes are on the ecu
corsacoley
Member

Registered: 13th Sep 07
Location: durham
User status: Offline
14th Sep 07 at 16:28   View User's Profile U2U Member Reply With Quote

it came up as a coil pack before, so i changed that, the leads and plugs. Thats when it was running on 3. But was just wonderin why its bein such a dick atm, hittin the limiter at 5k and stalling :S
gsirick
Member

Registered: 18th Feb 07
Location: mid-wales
User status: Offline
14th Sep 07 at 16:29   View User's Profile U2U Member Reply With Quote

ive got a c16xe gsi ecu if you need one, not sure if these are the same as the x16xe ones tho.
corsacoley
Member

Registered: 13th Sep 07
Location: durham
User status: Offline
14th Sep 07 at 16:48   View User's Profile U2U Member Reply With Quote

hmmm. im not that clued up, hopefully some1 will know. ill need the transponder ecu and chip if its got them too
gsirick
Member

Registered: 18th Feb 07
Location: mid-wales
User status: Offline
14th Sep 07 at 16:55   View User's Profile U2U Member Reply With Quote

its a non immobiliser type so wont be any good to you, some one on here might be more helpful

 
New Topic

New Poll

  Related Threads Author Forum Replies Views Last Post
people with new/better inlet manifolds!!??? MoNkEy MaGiC Help Zone, Modification and ICE Advice 10 1486
12th May 04 at 13:29
by broster
 
gsi a 1.6? harry23 Help Zone, Modification and ICE Advice 3 763
2nd Jul 04 at 10:59
by Greasemonkey
 
How to get the upper hand on a VTS supermike Help Zone, Modification and ICE Advice 33 1378
5th Aug 06 at 00:35
by Dave A
 
1400 1600 Matty_Moo_ Help Zone, Modification and ICE Advice 7 392
10th Mar 07 at 12:38
by warren.g
 
X14xe to X16xe kerr Help Zone, Modification and ICE Advice 13 333
29th Jun 07 at 15:04
by kerr
 

Corsa Sport » Message Board » Help Zone, Modification and ICE Advice » x16xe problems 28 database queries in 0.0186288 seconds