corsasport.co.uk
 

Corsa Sport » Message Board » Help Zone, Modification and ICE Advice » speedo stopped working ! ! ! ! RESULT ! ! ! ! ! :)


New Topic

New Poll
  <<  1    2  >> Subscribe | Add to Favourites

You are not logged in and may not post or reply to messages. Please log in or create a new account or mail us about fixing an existing one - register@corsasport.co.uk

There are also many more features available when you are logged in such as private messages, buddy list, location services, post search and more.


Author speedo stopped working ! ! ! ! RESULT ! ! ! ! ! :)
ciderman
Member

Registered: 11th Sep 04
Location: cumbria
User status: Offline
26th Feb 06 at 17:26   View User's Profile U2U Member Reply With Quote

well i dont know weather to shout HOORAY

OR

hang my head in shame

ive been checking things over again to see if i missed anything............
i also had a look under the middle console to see if i could see the reverse switch that was mentioned as a possible cause to my problem..............

i still havnt found the reverse switch, but i took another look in the fuse box, in particular at fuse 18.

just as before the fuse was fine and hadnt blown......
but then something hit me this time that didnt before.............

the condition of the fuse itself, it was an old type fuse (see pix), so i removed it and replaced it with a 20amp fuse which controls the hazard switch, then placed the old type 20amp fuse in the hazard light slot, and then tryed the hazards........................ and surprize surprize the hazards didnt work all of sudden, clean the contacts on the old type fuse and then replaced it and BINGO hazards are now working.

put it in reverse

reverse lights WORKING.

pushed the ciggy lighter in and

POP, now working.

took the car down the road and GUESS WHAT..............











YES YOU GUESSED IT working

so the whole problem was due to this little ba$tard

Dave A
USER UNDER INVESTIGATION - DO NOT TRADE

Registered: 10th Dec 03
Location: County Durham
User status: Offline
26th Feb 06 at 18:01   View User's Profile U2U Member Reply With Quote

that will teach you not to overlook the obvious
ciderman
Member

Registered: 11th Sep 04
Location: cumbria
User status: Offline
26th Feb 06 at 18:04   View User's Profile U2U Member Reply With Quote

quote:
Originally posted by corsa808
that will teach you not to overlook the obvious


lol
yeah we live n learn

thats 1 problem i wont over look again i can tell you lol

[Edited on 26-02-2006 by ciderman]
Planty02
Member

Registered: 5th Mar 05
Location: Burslem, Stoke-on-Trent
User status: Offline
26th Feb 06 at 21:39   View User's Profile U2U Member Reply With Quote

if i was you i would replace that ( and any other old style fuses) with new ones
ainsley_brader
Member

Registered: 24th Mar 02
Location: Tattershall, Lincolnshire
User status: Offline
26th Feb 06 at 21:56   View User's Profile U2U Member Reply With Quote

quote:
Originally posted by ainsley_brader
Turned out to be a 20amp fuse (no 18) cryptically labeled as KL15.





Did I not say this earlier on?

ciderman
Member

Registered: 11th Sep 04
Location: cumbria
User status: Offline
27th Feb 06 at 11:04   View User's Profile U2U Member Reply With Quote

quote:
Originally posted by ainsley_brader
quote:
Originally posted by ainsley_brader
Turned out to be a 20amp fuse (no 18) cryptically labeled as KL15.





Did I not say this earlier on?




yeah you were right in a roundabout sort of way

i did check fuse 18 when it was mentioned but it hadnt blown so i assumed it was fine and that wasnt the problem.

but like i say i never found out it was really fuse 18 until i had a closer inspection

thanks for everyone help on this
ciderman
Member

Registered: 11th Sep 04
Location: cumbria
User status: Offline
27th Feb 06 at 11:13   View User's Profile U2U Member Reply With Quote

quote:
Originally posted by Planty02
if i was you i would replace that ( and any other old style fuses) with new ones


yeah thats the next job on the list mate

  <<  1    2  >>
New Topic

New Poll

  Related Threads Author Forum Replies Views Last Post
dash bulbs Korsa Help Zone, Modification and ICE Advice 1 877
14th Mar 03 at 21:51
by FrankP
 
Desperate Speedo Help Needed! Pickup Help Zone, Modification and ICE Advice 12 1798
16th Mar 06 at 11:07
by SRi-Co
 
speedo not working JUGGA Help Zone, Modification and ICE Advice 7 1292
16th May 04 at 22:21
by Unr3al Rac3r
 
speedo help mickp Help Zone, Modification and ICE Advice 4 1254
15th Apr 05 at 16:12
by mickp
 
fault code 0500 help!! ciderman Help Zone, Modification and ICE Advice 1 1089
21st Nov 05 at 14:14
by ciderman
 

Corsa Sport » Message Board » Help Zone, Modification and ICE Advice » speedo stopped working ! ! ! ! RESULT ! ! ! ! ! :) 27 database queries in 0.0169110 seconds