corsasport.co.uk
 

Corsa Sport » Message Board » Help Zone, Modification and ICE Advice » Can any1 help, bro bought a 2.0 red top corsa last nite, problems lol » Post Reply

Combe Tickets

Post Reply
Who Can Post? All users can post new topics and all users can reply.
Icon:
Formatting Mode:
Normal
Advanced
Help

Insert Bold text Insert Italicized text Insert Underlined text Insert Centered text Insert a Hyperlink Insert Email Hyperlink Insert an Image Insert Code Formatted text Insert Quoted text
Message:
HTML is Off
Smilies are On
BB Code is On
[img] Code is On
Post Options: Disable smileys?
Turn BBCode off?
Receive email notification of new replies?

BeArDy

posted on 27th Oct 08 at 12:01

Have you checked ICV to see if its stuck open?
Try squeezing the pipe with go's to the top hat an see if the rev's drop.
As for the smoke, is it when you nail it you get smoke and then it go's away higher up the rev's?
Could be your valve stem oil seals, had it alot of high milage C20XE's which have had a hard life.

My money is on stuck open ICV and valve stem oil seals.


Torsa g

posted on 27th Oct 08 at 11:30

Does the eml light come on when turning ignition on


Wayne

posted on 27th Oct 08 at 10:44

sorry to sound stupid but what's the CTS?


corsa_godfather

posted on 26th Oct 08 at 18:28

Also noticed on the rocker cover where the 2 breather pipes go on the one on the left has no pipe on it so do you's think where thats suppose to plug in on the throttle body must be lyin open which mite becausing it to run wrong aswell?


corsa_godfather

posted on 26th Oct 08 at 17:59

well my pal tried to plug his computer into it today n nothing was coming up but error lol, still runnig high rev's, was thinkin maybe the choke is stuck on?? its alot of blue/black smoke out the back when givin it stick


VegasPhil

posted on 25th Oct 08 at 13:35

If he's changed the AFM then take your time to look round all of the hoses for a Vac Leak. When mine had a split it idled irratically.

I'd be runing to the vauxhall parts desk to get a nice new CTS next, should get change from a tenner :)

Then take off the ICV. It's a metal cylinder thing that is a pig to get to. Make sure that it is nice and clean, I cleaned mine with some Brake cleaner then a bit of WD40 down there and put it back together.

What induction kit is on there? Is the filter nice and clean?


scotts v6

posted on 25th Oct 08 at 13:08

make sure the knock and crank cencers are the rite wa round my mates car used to do this wopt them over ran fine


craig_s

posted on 24th Oct 08 at 23:48

sound's like it's overfueling,imo the first thing to change would be the cts,then see how that goes.

cts controls the coldstart so it could be keeping the engine on coldstart which could explain the overfueling and high idle.although is still shouldn't be at 1500 rpm.


Mark B

posted on 24th Oct 08 at 23:13

my c16se i had in my corsa used to jerk and chug all the time and hen it donw it the rev counter went up and down like mad it was a dodgy wire


corsa_godfather

posted on 24th Oct 08 at 21:03

ill check that out in the morning m8, thanks


braggy

posted on 24th Oct 08 at 21:00

when u turn the igintion on the eml should come on the dash? then go out when started?


corsa_godfather

posted on 24th Oct 08 at 20:56

no eml light on m8, he said he fitted a new afm on wed jus there, dont even know if eml light is hooked up


braggy

posted on 24th Oct 08 at 20:54

it could be a afm, but it would put the eml on?
i have a afm if needed!!


corsa_godfather

posted on 24th Oct 08 at 20:42

is that no the air flow meter m8? im hopeless wi this stuff lol


braggy

posted on 24th Oct 08 at 20:39

unburnt fuel=black smoke
and the idle is coz u need to clean icv or buy one from me!!


corsa_godfather

posted on 24th Oct 08 at 20:37

Hi guys, bought a red top corsa last nite, car goes ok, but it idles at 1500rpm n when ya give it stick its puffin alot of black smoke, boy said he replaced the afm n its no helped any, any ideas guys??

n also in the mornin when i start it up once its started the rev counter flys away round couple a times then sits back at 1500rpm lol???

hopefully its al nothin too major, i was thinkin if the car had a lamda sensor maybe that would be knackered?? horrible smell out exhaust when i stuck my head out the car when reversing this mornin

any ideas would be great, thanks